码迷,mamicode.com
首页 > 其他好文 > 详细

计算两点间距离

时间:2020-01-31 12:39:23      阅读:54      评论:0      收藏:0      [点我收藏+]

标签:sample   sam   pre   std   方法   namespace   类方法   str   输出   

输入两点坐标(X1,Y1),(X2,Y2),计算并输出两点间的距离。

Input输入数据有多组,每组占一行,由4个实数组成,分别表示x1,y1,x2,y2,数据之间用空格隔开。Output对于每组输入数据,输出一行,结果保留两位小数。Sample Input

0 0 0 1
0 1 1 0

Sample Output

1.00
1.41


#include<iostream>
#include<math.h>
#include<iomanip>
#include<stdio.h>
using namespace std;
class Point{
public:
void func1(double x,double y)
{
m_x=x;
m_y=y;
}
double func2(Point &another)
{
double a;
a=sqrt((m_x-another.m_x)*(m_x-another.m_x)+(m_y-another.m_y)*(m_y-another.m_y));
return a;
}
private:
double m_x,m_y;
};
int main()
{
double x,y;
Point p1,p2;
cin>>x>>y;
p1.func1(x,y);
cin>>x>>y;
p2.func1(x,y);
double z;
z=p1.func2(p2);
cout<<fixed<<setprecision(2)<<z<<endl;
return 0;
}

用类方法练习了一下。

计算两点间距离

标签:sample   sam   pre   std   方法   namespace   类方法   str   输出   

原文地址:https://www.cnblogs.com/heroin1/p/12244895.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!