码迷,mamicode.com
首页 > 其他好文 > 详细

实验10-1 圆形体体积计算器 (20分)

时间:2020-01-31 18:51:21      阅读:784      评论:0      收藏:0      [点我收藏+]

标签:lang   default   line   clip   include   com   scripts   半径   fonts   

本题要求实现一个常用圆形体体积的计算器。计算公式如下:

  • 球体体积 V=?3??4??πr?3??,其中r是球体半径。
  • 圆柱体体积 V=πr?2??h,其中r是底圆半径,h是高。
  • 圆锥体体积 V=?3??1??πr?2??h,其中r是底圆半径,h是高。

输入格式:

在每次计算之前,要求输出如下界面:

1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
 

然后从标准输入读进一个整数指令。

输出格式:

如果读入的指令是1或2或3,则执行相应的体积计算;如果是其他整数,则程序结束运行。

  • 当输入为1时,在计算球体体积之前,打印Please enter the radius:,然后读入球体半径,完成计算;
  • 当输入为2时,在计算圆柱体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算;
  • 当输入为3时,在计算圆锥体体积之前,打印Please enter the radius and the height:,然后读入底圆半径和高,完成计算。

计算结果在一行内输出,保留小数点后两位。

输入样例:

1
2
3
2.4 3
0
 

输出样例:

1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius:
33.51
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:
Please enter the radius and the height:
18.10
1-Ball
2-Cylinder
3-Cone
other-Exit
Please enter your command:

代码:
#include <stdio.h>
#include <string.h>
#include <math.h>
#define PI acos(-1)
int main() {
    int d,flag = 0;
    double r,h;
    printf("1-Ball\n2-Cylinder\n3-Cone\nother-Exit\nPlease enter your command:\n");
    while(scanf("%d",&d)) {
        switch(d) {
            case 1:
                printf("Please enter the radius:\n");
                scanf("%lf",&r);
                printf("%.2f\n",PI * 4 / 3 * r * r * r);
                break;
            case 2:
                printf("Please enter the radius and the height:\n");
                scanf("%lf%lf",&r,&h);
                printf("%.2f\n",PI * r * r * h);
                break;
            case 3:
                printf("Please enter the radius and the height:\n");
                scanf("%lf%lf",&r,&h);
                printf("%.2f\n",PI * r * r * h / 3);
                break;
            default: flag = 1;
        }
        if(flag) break;
        printf("1-Ball\n2-Cylinder\n3-Cone\nother-Exit\nPlease enter your command:\n");
    }
}

 

实验10-1 圆形体体积计算器 (20分)

标签:lang   default   line   clip   include   com   scripts   半径   fonts   

原文地址:https://www.cnblogs.com/8023spz/p/12245945.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!