码迷,mamicode.com
首页 > 其他好文 > 详细

HDoj 1002 A + B Problem II

时间:2020-02-01 16:13:15      阅读:69      评论:0      收藏:0      [点我收藏+]

标签:ted   RoCE   esc   sts   cin   line   nat   put   sele   


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

Author
Ignatius.L

Recommend
We have carefully selected several similar problems for you: 1004 1003 1008 1005 1089

#include<iostream>
#include<stdio.h>
#include<string>
using namespace std;
int main()
{
    string s1="";
    string s2="";
    string s3="";
    int n;
    int length=0;
    cin>>n; 
    int num=1; 
    while(n--)
    {
        cin>>s1>>s2;
        string s4=s2;
        string s5=s1;
        if(s1.length()>s2.length())
        {
            length=s1.length();
        }
        else
        {
            s3=s1;
            s1=s2;
            s2=s3;
            length=s1.length();
        }
        s3=string(s1.length()-s2.length(),0);
        s2=s3+s2;
        //cout<<s1<<s2; 
        string temp="0";
        int t=0;
        for(int i=length-1;i>=0;i--)
        {
            t=((s1[i]-48)+(s2[i]-48)+(temp[0]-48));
            s1[i]=t%10+48;
            if(t>=10)
            temp[0]=1;
            else
            temp[0]=0;
            
        } 
        cout<<"Case"<<" "<<num++<<":"<<endl;
        if(t>=10)
        cout<<s5<<" + "<<s4+" = "<<"1"<<s1<<endl;
        else
        cout<<s5<<" + "<<s4+" = "<<s1<<endl; 
        if(n!=0)
        cout<<endl; 
        
        
    }
    
    return 0;
}
//注意!!!!!!!!!!!!!!!!!!!!!!!!!!最后一行不要输出空行

 

HDoj 1002 A + B Problem II

标签:ted   RoCE   esc   sts   cin   line   nat   put   sele   

原文地址:https://www.cnblogs.com/wzmm/p/12248726.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!