码迷,mamicode.com
首页 > 其他好文 > 详细

Cow Bowling

时间:2020-02-02 19:42:09      阅读:74      评论:0      收藏:0      [点我收藏+]

标签:reac   standard   sep   name   other   sample   max   Plan   term   

The cows don‘t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

          7


3 8

8 1 0

2 7 4 4

4 5 2 6 5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow‘s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample: 

          7

*
3 8
*
8 1 0
*
2 7 4 4
*
4 5 2 6 5
The highest score is achievable by traversing the cows as shown above.

dp题目,每个点的最高分只和左上方和上方的最高分有关

dp[i][j] = max(dp[i - 1][j - 1], dp[i - 1][j]) + map[i][j];

注意要从所有点里面找max值

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
using namespace std;

int max(int a, int b) {
    return a > b ? a : b;
}

int main() {
    int n;


    while (cin >> n) {
        int map[401][401] = { 0 };
        int dp[401][401] = { 0 };
        for (int i = 1; i <= n; i++) {
            for (int j = 1; j <= i; j++) {
                cin >> map[i][j];
            }
        }
        int mmax = 0;
        for (int i = 1; i <= n; i++) {
            for (int j = 1; j <= i; j++) {
                dp[i][j] = max(dp[i - 1][j - 1], dp[i - 1][j]) + map[i][j];
                if (mmax < dp[i][j]) {
                    mmax = dp[i][j];
                }
            }
        }
        cout << mmax << endl;
    }



    return 0;
}

 

Cow Bowling

标签:reac   standard   sep   name   other   sample   max   Plan   term   

原文地址:https://www.cnblogs.com/Vetsama/p/12253108.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!