码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 6182A Math Problem(快速幂)

时间:2020-02-04 12:22:03      阅读:55      评论:0      收藏:0      [点我收藏+]

标签:system   ext   code   integer   new   oid   ++   注意   cat   

You are given a positive integer n, please count how many positive integers k satisfy kknkk≤n. 

InputThere are no more than 50 test cases. 

Each case only contains a positivse integer n in a line. 

1n10^18
OutputFor each test case, output an integer indicates the number of positive integers k satisfy k^k ≤ n in a line.

Sample Input

1
4

Sample Output

1
2
主要注意long最大为多少 2^63-1,先求出来,就知道15^15正好小于,16^16就超long的范围

代码:
import java.math.BigInteger;
import java.util.Scanner;

public class Main{
        static long quick_pow(long a, long b){
                long res = 1;
                while(b > 0){
                        if((b&1) == 1) res = res * a;
                        a = a * a;
                        b >>= 1;
                }
                return res;
        }
        public static void main(String[] args) {
                Scanner scan=new Scanner(System.in);
//                BigInteger a=new BigInteger("2");
//                System.out.println(a.pow(64));
//                for(int i=1;i<=20;i++)
//                    System.out.println(quick_pow(i,i));
                while(scan.hasNext()){
                        int cnt=15;
                        long n=scan.nextLong();
                        for(long i=15;i>=1;i--){
                                if(quick_pow(i,i)>n) cnt--;
                                else break;
                        }
                        System.out.println(cnt);
                }
        }
}

 

hdu 6182A Math Problem(快速幂)

标签:system   ext   code   integer   new   oid   ++   注意   cat   

原文地址:https://www.cnblogs.com/qdu-lkc/p/12258893.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!