码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 2053 Switch Game

时间:2020-02-04 15:40:35      阅读:71      评论:0      收藏:0      [点我收藏+]

标签:cannot   follow   模拟   c代码   condition   语言   put   who   hang   

Switch Game
原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=2053
Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Problem Description
There are many lamps in a line. All of them are off at first. A series of operations are carried out on these lamps. On the i-th operation, the lamps whose numbers are the multiple of i change the condition ( on to off and off to on ).
 
 
Input
Each test case contains only a number n ( 0< n<= 10^5) in a line.
  ————————————————————————————
Output
Output the condition of the n-th lamp after infinity operations ( 0 - off, 1 - on ).
 ——————————————————————————————————
Sample Input
1
5
 ——————————————————————————————
Sample Output
1
0
————————————————————————————————
hint
Consider the second test case:
The initial condition    : 0 0 0 0 0 …
After the first operation  : 1 1 1 1 1 …
After the second operation : 1 0 1 0 1 …
After the third operation  : 1 0 0 0 1 …
After the fourth operation : 1 0 0 1 1 …
After the fifth operation  : 1 0 0 1 0 …
The later operations cannot change the condition of the fifth lamp any more. So the answer is 0.
————————————————————————————————————————————————————
题目大意:有n个灯泡排成一列,所有灯泡的初始状态都是关闭的,现在对这些灯泡做开关操作:在第n次操作时,号码是n的倍数的灯状态改变(开变为闭,闭变开)
 
 
尝试一下模拟第n次灯泡的状态
c语言AC代码:
#include<stdio.h>
int main()
{
        int n;
        while(scanf("%d",&n)!=EOF)
        {
            int t=0;       //初始状态为0
            for(int i=1;i<=n;i++)  //用for循环模拟第n次的灯泡状态
            {
                if(n%i==0)    
                {      //如果n是操作次数i的倍数,则改变灯泡状态
                    t=!t; 
                }
            }
            printf("%d\n",t);//输出第n个灯泡的状态
        }

        return 0;

}

 

 
 

HDU 2053 Switch Game

标签:cannot   follow   模拟   c代码   condition   语言   put   who   hang   

原文地址:https://www.cnblogs.com/ziggystardust-pop/p/12259508.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!