码迷,mamicode.com
首页 > 其他好文 > 详细

PAT Advanced 1132 Cut Integer (20) [数学问题-简单数学]

时间:2020-02-04 20:30:33      阅读:70      评论:0      收藏:0      [点我收藏+]

标签:字符串截取   amp   pre   string   log   tee   mes   name   author   

题目

Cutting an integer means to cut a K digits long integer Z into two integers of (K/2) digits long integers A and B. For example, afer cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 x 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<= 20). Then N lines follow, each gives an integer Z (10<=Z<=231). It is guaranteed that the number of digits of Z is an even number.
Output Specification:
For each case, print a single line “Yes” if it is such a number, or “No” if not.
Sample Input:
3
167334
2333
12345678
Sample Output:
Yes
No
No

题目分析

已知偶数K位正整数N,从中间分为两部分其长度相等的A,B两数,若N能被(A+B)整除,就满足条件,输出Yes,否则输出No

解题思路

  1. 字符串截取左右部分
  2. N%(A+B)==0 -- Yes

易错点

  1. A*B有可能为0,如:N=10

Code

#include <iostream>
#include <string>
using namespace std;
int main(int argc,char * argv[]) {
    int n,z;
    scanf("%d",&n);
    for(int i=0; i<n; i++) {
        scanf("%d",&z);
        string s= to_string(z);
        int l = stoi(s.substr(0,s.length()/2));
        int r = stoi(s.substr(s.length()/2,s.length()/2));
        if(l*r!=0&&z%(l*r)==0) //l*r可能为0,比如10,测试点2,3 
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}


PAT Advanced 1132 Cut Integer (20) [数学问题-简单数学]

标签:字符串截取   amp   pre   string   log   tee   mes   name   author   

原文地址:https://www.cnblogs.com/houzm/p/12260616.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!