码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5090 二分匹配

时间:2014-11-03 22:34:19      阅读:258      评论:0      收藏:0      [点我收藏+]

标签:二分匹配

Game with Pearls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 172    Accepted Submission(s): 103


Problem Description
Tom and Jerry are playing a game with tubes and pearls. The rule of the game is:

1) Tom and Jerry come up together with a number K.

2) Tom provides N tubes. Within each tube, there are several pearls. The number of pearls in each tube is at least 1 and at most N.

3) Jerry puts some more pearls into each tube. The number of pearls put into each tube has to be either 0 or a positive multiple of K. After that Jerry organizes these tubes in the order that the first tube has exact one pearl, the 2nd tube has exact 2 pearls, …, the Nth tube has exact N pearls.

4) If Jerry succeeds, he wins the game, otherwise Tom wins.

Write a program to determine who wins the game according to a given N, K and initial number of pearls in each tube. If Tom wins the game, output “Tom”, otherwise, output “Jerry”.
 

Input
The first line contains an integer M (M<=500), then M games follow. For each game, the first line contains 2 integers, N and K (1 <= N <= 100, 1 <= K <= N), and the second line contains N integers presenting the number of pearls in each tube.
 

Output
For each game, output a line containing either “Tom” or “Jerry”.
 

Sample Input
2 5 1 1 2 3 4 5 6 2 1 2 3 4 5 5
 

Sample Output
Jerry Tom
 

Source
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <algorithm>
#include <iostream>
#include <queue>
#include <stack>
#include <deque>
#include <vector>
#include <set>
//#include <map>
#include <memory.h>
using namespace std;

int map[110],pp[110][110],n,vis[110];

int BFS(int x){
    int i;
    for(i=1;i<=n;i++){
        if(!vis[i] && pp[x][i]){
            vis[i] = 1;
            if(!map[i] || BFS(map[i])){
                map[i] = x;
                return 1;
            }
        }
    }

    return 0;
}

int main(){
    int t,i,a[110],k;

    while(~scanf("%d",&t)){
        while(t--){
            scanf("%d%d",&n,&k);
            memset(pp,0,sizeof(pp));
            memset(map,0,sizeof(map));
            for(i=0;i<n;i++){
                scanf("%d",&a[i]);
            }
            for(i=0;i<n;i++){
                int tt = a[i];
                while(tt<=n && a[i]<=n){
                    pp[a[i]][tt] = 1;
                    tt+=k;
                }
            }
            int count = 0;
            for(i=0;i<n;i++){
                memset(vis,0,sizeof(vis));
                if(BFS(a[i]) == 1){
                    count++;
                }
            }
            if(count == n){
                printf("Jerry\n");
            }
            else{
                printf("Tom\n");
            }
        }
    }

    return 0;
}


HDU 5090 二分匹配

标签:二分匹配

原文地址:http://blog.csdn.net/zcr_7/article/details/40748831

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!