码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-4847-Wow! Such Doge!

时间:2014-11-03 22:38:23      阅读:276      评论:0      收藏:0      [点我收藏+]

标签:algorithm   hdu   c++   水题   iostream   

Wow! Such Doge!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 808    Accepted Submission(s): 509


Problem Description
bubuko.com,布布扣

Chen, Adrian (November 7, 2013). “Doge Is An Ac- tually Good Internet Meme. Wow.”. Gawker. Retrieved November 22, 2013.

Doge is an Internet meme that became popular in 2013. The meme typically con- sists of a picture of a Shiba Inu dog ac- companied by multicolored text in Comic Sans MS font in the foreground. The text, representing a kind of internal monologue, is deliberately written in broken English, and usually contains the word “wow” and the phrases “such x”, “much x”, “many x”, “very x” and “so x”.
Kabosu, the Shiba Inu featured in the original meme, was first pictured in a 2010 blog post by Atsuko Sato, a Japanese kindergarten teacher. Afterwards, varia- tions of the pictures using overlaid Comic Sans text were posted from a Tumblr blog, Shiba Confessions. However, the use of the intentionally misspelled “doge” dates back to June 2005, when it was mentioned in an episode of Homestar Runners puppet series.
In August 2013, images of the meme were spammed on Reddit’s r/MURICA subreddit by 4chan’s random imageboard, /b/. A search of the term doge on Google Trends shows an explosion of popularity occurring in October 2013, and more so in the following month. By November 2013, the meme had become widespread on the Internet. Google later created a Doge Easter egg: when doge meme was entered into the YouTube search bar, all of the site’s text would be displayed in colorful Comic Sans, similar to the kind used by the meme.
The meme was ranked #12 on MTV’s list of “50 Things Pop Culture Had Us Giving Thanks For” in 2013. Io9 compared the internal dialog of the Shiba Inu dogs to lolcat-speak. The image most commonly associated with the meme is of a female Shiba Inu named Kabosu, taken from a Japanese blog documenting the dog’s daily activities. The spelling of doge has several variants, leading to debate on its actual pronunciation. On December 13, Doge was named the “top meme” of 2013 by Know Your Meme.
In December 2013, the Dogecoin was introduced as a new cryptocurrency, making it the first cryptocurrency to be based on an Internet meme; the viral phenomenon, along with usage of the Comic Sans MS typeface, gave it “the Internet density of a large star” according to Medium writer Quinn Norton.
In late December 2013, members of the U.S. Congress produced material in the meme’s style. Huffington Post commented that Doge was “killed” because of the Congress members’ usage of the meme.
By early 2014, Doge’s popularity was sustained by internet communities on social media, accompanied by the rapid growth and acceptance of Dogecoin. In April 2014, Doge experienced a second major media resurgence due to revelations of the Dogecoin community’s intent to sponsor Josh Wise in NASCAR and place a picture of the Shiba Inu on his vehicle.

—— Doge (meme). (2014, May 18).
In Wikipedia, The Free Encyclopedia. Retrieved 02:00, May 22, 2014, from
http://en.wikipedia.org/w/index.php?title=Doge_(meme)&oldid=609040691

Now, Doge wants to know how many words “doge” are there in a given article. Would you like to help Doge solve this problem?
 

Input
An article that Doge wants to know.
The size of the article does not exceed 64KB. The article contains only ASCII characters.
 

Output
Please output the number of word “doge” (case-insensitive). Refer to the samples for more details.
 

Sample Input
adoge cutedo yourge blownDoge lovelyDooge Wow! Such Dooooooooooooooge!!! D0ge dOge DOGE dogedoge
 

Sample Output
6
 

Source
 


今天又做点题,ZY挂的,貌似很难,反正现在我是刷不动。。。

看了看水题,还是水题好做,:-(

注意:这题只要一组数据输入到文件结束,然后输出ans,可以按Ctrl + Z结束输入,然后看ans的值

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define maxn 1000
using namespace std;

int main()
{
	char a[10]="doge", b[maxn];
	int ans=0, flag, i, j;
	while(gets(b))
	{
		int len = strlen(b);
		for(i=0; i<len-3; i++)
		{
			flag=0;
			for(j=i; j<=i+3; j++)
			{
				if((a[j-i] != b[j]) && (a[j-i]-32 != b[j]) )
				{
					flag=1;
					break;
				} 
			}
			if(!flag) ans++;
		}
	}
	printf("%d\n", ans);
	return 0;
}


HDU-4847-Wow! Such Doge!

标签:algorithm   hdu   c++   水题   iostream   

原文地址:http://blog.csdn.net/u014355480/article/details/40748161

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!