码迷,mamicode.com
首页 > 其他好文 > 详细

1020 月饼 (25分)

时间:2020-02-20 10:14:54      阅读:66      评论:0      收藏:0      [点我收藏+]

标签:mes   单位   中秋   smo   取出   namespace   this   his   str   

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

输入格式:

每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

输出格式:

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

输入样例:

3 20
18 15 10
75 72 45

      
    

输出样例:

94.50

代码

// 1020 月饼.cpp : 此文件包含 "main" 函数。程序执行将在此处开始并结束。
//

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

struct cake {
    int money;//总金额
    int amount;//数量
    double price;//单价
};

bool cmp(cake a, cake b) {
    return a.price > b.price;
}
int amount[1010];
int money[1010];

int main()
{
    int n, d;//n种月饼,d需求量
    cin >> n >> d;
    
    //先存储库存量,然后存储总售价
    int thismoney, thisamount;
    for (int i = 0; i < n; i++) {
        cin >>  thisamount;
        amount[i] = thisamount;
    }
    for (int i = 0; i < n; i++) {
        cin >> thismoney;
        money[i] = thismoney;
    }
    //封装到vector容器中
    vector<cake> v;
    for (int i = 0; i < n; i++) {
        cake c;
        c.amount = amount[i];
        c.money = money[i];
        c.price = (double)money[i] / amount[i];
        v.push_back(c);
    }
    sort(v.begin(),v.end(),cmp);
    double earn = 0.0;
    int i = 0;
    while (d > 0) {
        if (v[i].amount > d) {
            earn += v[i].price * d;
            d = 0;
        }
        else {
            earn += v[i].money;
            d -= v[i].amount;
        }
        i++;
    }
    printf("%.2f",earn);
    return 0;
}

1020 月饼 (25分)

标签:mes   单位   中秋   smo   取出   namespace   this   his   str   

原文地址:https://www.cnblogs.com/ericling/p/12334307.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!