码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4791 Alice's Print Service (DP+离线处理)

时间:2014-11-04 13:10:01      阅读:148      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   color   ar   os   java   for   sp   

Alice‘s Print Service

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1163    Accepted Submission(s): 270


Problem Description
Alice is providing print service, while the pricing doesn‘t seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It‘s easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.
 

Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 105 ). The second line contains 2n integers s1, p1 , s2, p2 , ..., sn, pn (0=s1 < s2 < ... < sn≤ 109 , 109 ≥ p1 ≥ p2 ≥ ... ≥ pn ≥ 0).. The price when printing no less than si but less than si+1 pages is pi cents per page (for i=1..n-1). The price when printing no less than sn pages is pn cents per page. The third line containing m integers q1 .. qm (0 ≤ qi ≤ 109 ) are the queries.
 

Output
For each query qi, you should output the minimum amount of money (in cents) to pay if you want to print qi pages, one output in one line.
 

Sample Input
1 2 3 0 20 100 10 0 99 100
 

Sample Output
0 1000 1000
 


题意:给n种方案,打印量≥ si 时,每张纸的打印价格为pi(0≤n≤100000),问打印m次

询问,打印 qi 张时最少需要多少钱(0≤m≤100000)。


思路 : 先将询问都储存起来,然后按需求从小到大排序,依次求出答案,最后再输出。


#include <iostream>
#include <algorithm>
#include <cstdio>
#define ll long long
using namespace std;
const int maxn=100005;

struct node
{
    ll s,p,cost;
}a[maxn];
struct code
{
    int index;
    ll ans,num;
}b[maxn];
int n,m;

bool cmp1(code p,code q)
{
    return p.num<q.num;
}

bool cmp2(code p,code q)
{
    return p.index<q.index;
}

void input()
{
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++)  scanf("%I64d%I64d",&a[i].s,&a[i].p);
    for(int i=0;i<m;i++)
    {
         scanf("%I64d",&b[i].num);
         b[i].index=i+1;
    }
    sort(b,b+m,cmp1);
}

void solve()
{
    a[n-1].cost=a[n-1].s*a[n-1].p;
    for(int i=n-2;i>=0;i--)  a[i].cost=min(a[i].s*a[i].p,a[i+1].cost);

    int cnt=0;
    for(int i=0;i<m;i++)
    {
         while(cnt<n && a[cnt].s<=b[i].num)  cnt++;
         if(cnt==n)  b[i].ans=b[i].num*a[n-1].p;
         else  b[i].ans=min(b[i].num*a[cnt-1].p,a[cnt].cost);
    }
    sort(b,b+m,cmp2);
    for(int i=0;i<m;i++)   printf("%I64d\n",b[i].ans);
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        input();
        solve();
    }
    return 0;
}




hdu 4791 Alice's Print Service (DP+离线处理)

标签:des   style   io   color   ar   os   java   for   sp   

原文地址:http://blog.csdn.net/u012596172/article/details/40783045

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!