码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3096 Surprising Strings

时间:2014-11-04 17:31:40      阅读:192      评论:0      收藏:0      [点我收藏+]

标签:poj   算法   编程   c++   

Surprising Strings
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6017   Accepted: 3934

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

题意:给你个字符串例如abcd,距离为0的字符串有ab,bc,cd,距离为1的字符串有ac,bc,距离为2的字符串有ad,如果不存在在相同距离下的两个字符串相同,则这个字符串是surprising,否则是NOT surprising;


#include <iostream>
#include <string.h>
using namespace std;
int main(){
	char s[100];
	while (cin>>s){
		if (strcmp(s,"*")==0)
				break;
		int len=strlen(s),flag=0;
		for (int i=0;i<len;i++){
			for (int j=i+1;j<len;j++){
				if (s[i]==s[j]){
					for (int k=1;k<len-j;k++){
						if (s[k+i]==s[k+j]){
							flag=1;
							goto A;
						}
					}
				}
			}
		}
		A:
		if (flag==0)
			cout<<s<<" is surprising."<<endl;
		else
			cout<<s<<" is NOT surprising."<<endl;
	}
	return 0;
}


poj 3096 Surprising Strings

标签:poj   算法   编程   c++   

原文地址:http://blog.csdn.net/codeforcer/article/details/40786021

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!