标签:des style blog http io color ar os java
Game with Pearls
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 196 Accepted Submission(s): 120
Problem Description
Tom and Jerry are playing a game with tubes and pearls. The rule of the game is:
1) Tom and Jerry come up together with a number K.
2) Tom provides N tubes. Within each tube, there are several pearls. The number of pearls in each tube is at least 1 and at most N.
3) Jerry puts some more pearls into each tube. The number of pearls put into each tube has to be either 0 or a positive multiple of K. After that Jerry organizes these tubes in the order that the first tube has exact one pearl, the 2nd tube has exact 2 pearls,
…, the Nth tube has exact N pearls.
4) If Jerry succeeds, he wins the game, otherwise Tom wins.
Write a program to determine who wins the game according to a given N, K and initial number of pearls in each tube. If Tom wins the game, output “Tom”, otherwise, output “Jerry”.
Input
The first line contains an integer M (M<=500), then M games follow. For each game, the first line contains 2 integers, N and K (1 <= N <= 100, 1 <= K <= N), and the second line contains N integers presenting the number of pearls in each tube.
Output
For each game, output a line containing either “Tom” or “Jerry”.
Sample Input
2
5 1
1 2 3 4 5
6 2
1 2 3 4 5 5
Sample Output
题意:Jerry 和 Tom 玩一个游戏 , 给你 n 个盒子 , a[ i ] 表示开始时 ,第 i 个盒子中的小球的个数 。 然后 Jerry 可以在每个
盒子里加入 0 或 k的倍数的小球 , 操作完后,Jerry 可以重新排列 盒子的顺序,最终使 第 i 个盒子中有 i 个小球。 若Jerry能
使最终的盒子变成那样,就输出 “Jerry” ,否则 输出 “Tom” 。
思路: 最大匹配,以样例二为例 :
然后求出最大匹配数cnt ,若 cnt = = n ,输出 “Jerry” ,否则 输出 “Tom” 。
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn = 110 ;
bool con[maxn][maxn],vis[maxn];
int match[maxn],n,k,x;
void initial()
{
memset(con,0,sizeof(con));
memset(match,-1,sizeof(match));
}
void input()
{
scanf("%d %d",&n,&k);
for(int i=1;i<=n;i++)
{
scanf("%d",&x);
while(x<=n)
{
con[x][i]=1;
x+=k;
}
}
}
bool dfs(int x)
{
for(int i=1;i<=n;i++)
{
if(!vis[i] && con[x][i])
{
vis[i]=1;
if(match[i]==-1 || dfs(match[i]))
{
match[i]=x;
return true;
}
}
}
return false;
}
void solve()
{
int cnt=0;
for(int i=1;i<=n;i++)
{
memset(vis,0,sizeof(vis));
if(dfs(i)) cnt++;
}
if(cnt==n) printf("Jerry\n");
else printf("Tom\n");
}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
initial();
input();
solve();
}
return 0;
}
hdu 5090 Game with Pearls(最大匹配)
标签:des style blog http io color ar os java
原文地址:http://blog.csdn.net/u012596172/article/details/40784773