码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1231 最大连续子序列

时间:2020-03-04 00:31:58      阅读:54      评论:0      收藏:0      [点我收藏+]

标签:定义   ios   整数   中间   can   ace   正整数   desc   type   

Problem Description

给定K个整数的序列{ N1, N2, ..., NK },其任意连续子序列可表示为{ Ni, Ni+1, ...,
Nj },其中 1 <= i <= j <= K。最大连续子序列是所有连续子序列中元素和最大的一个,
例如给定序列{ -2, 11, -4, 13, -5, -2 },其最大连续子序列为{ 11, -4, 13 },最大和
为20。
在今年的数据结构考卷中,要求编写程序得到最大和,现在增加一个要求,即还需要输出该
子序列的第一个和最后一个元素。

Input

测试输入包含若干测试用例,每个测试用例占2行,第1行给出正整数K( < 10000 ),第2行给出K个整数,中间用空格分隔。当K为0时,输入结束,该用例不被处理。

Output

对每个测试用例,在1行里输出最大和、最大连续子序列的第一个和最后一个元
素,中间用空格分隔。如果最大连续子序列不唯一,则输出序号i和j最小的那个(如输入样例的第2、3组)。若所有K个元素都是负数,则定义其最大和为0,输出整个序列的首尾元素。

Sample Input

6
-2 11 -4 13 -5 -2
10
-10 1 2 3 4 -5 -23 3 7 -21
6
5 -8 3 2 5 0
1
10
3
-1 -5 -2
3
-1 0 -2
0

Sample Output

20 11 13
10 1 4
10 3 5
10 10 10
0 -1 -2
0 0 0
 

这个题就和hdu 1003一样 https://www.cnblogs.com/wz-archer/p/12257676.html

把原来写的代码改了改就直接过了

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <cmath>
#include <map>

using namespace std;
typedef long long ll;

const double inf=1e20;
const int maxn=1e5+10;
const int mod=1e9+7;

int a[maxn];
int l[maxn],maxi,maxx[maxn],mx;

int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
        if(n==0)break;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
        }
        maxi=0;
        mx=maxx[0]=a[0];
        l[0]=0;
        for(int i=1;i<n;i++){
            if(maxx[i-1]+a[i]>0&&maxx[i-1]>0){
                l[i]=l[i-1];
                maxx[i]=maxx[i-1]+a[i];
            }else{
                maxx[i]=a[i];
                l[i]=i;
            }
            if(maxx[i]>mx){
                mx=maxx[i];
                maxi=i;
            }
        }
        //printf("Case %d:\n",tt-t);
        if(maxx[maxi]<0)
            printf("%d %d %d\n",0,a[0],a[n-1]);
        else
            printf("%d %d %d\n",maxx[maxi],a[l[maxi]],a[maxi]);
    }
    return 0;
}

 

hdu 1231 最大连续子序列

标签:定义   ios   整数   中间   can   ace   正整数   desc   type   

原文地址:https://www.cnblogs.com/wz-archer/p/12405654.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!