码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2003 求绝对值

时间:2020-03-05 11:48:59      阅读:53      评论:0      收藏:0      [点我收藏+]

标签:problem   algo   string   algorithm   scan   span   code   color   tle   

Problem Description

求实数的绝对值

Input

输入数据有多组,每组占一行,每行包含一个实数。

Output

对于每组输入数据,输出它的绝对值,要求每组数据输出一行,结果保留两位小数。

Sample Input

123
-234.00

Sample Output

123.00
234.00
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <cmath>
#include <map>

using namespace std;
typedef long long ll;

const double inf=1e20;
const int maxn=2e5+10;
const int mod=1e9+7;

int main(){
    double n;
    while(scanf("%lf",&n)!=EOF){
        if(n<0)n=-n;
        printf("%.2lf\n",n);
    }
    return 0;
}

 

hdu 2003 求绝对值

标签:problem   algo   string   algorithm   scan   span   code   color   tle   

原文地址:https://www.cnblogs.com/wz-archer/p/12419285.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!