码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2017 字符串统计

时间:2020-03-06 19:14:11      阅读:45      评论:0      收藏:0      [点我收藏+]

标签:max   turn   desc   style   nbsp   std   def   pac   printf   

Problem Description

对于给定的一个字符串,统计其中数字字符出现的次数。

Input

输入数据有多行,第一行是一个整数n,表示测试实例的个数,后面跟着n行,每行包括一个由字母和数字组成的字符串。

Output

对于每个测试实例,输出该串中数值的个数,每个输出占一行。

Sample Input

2
asdfasdf123123asdfasdf
asdf111111111asdfasdfasdf

Sample Output

6
9
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <cmath>
#include <map>

using namespace std;
typedef long long ll;

const double inf=1e20;
const int maxn=2e5+10;
const int mod=1e9+7;

char a[maxn];

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%s",a);
        int len=strlen(a);
        int num=0;
        for(int i=0;i<len;i++){
            if(a[i]>=0&&a[i]<=9)num++;
        }
        printf("%d\n",num);
    }
    return 0;
}

 

hdu 2017 字符串统计

标签:max   turn   desc   style   nbsp   std   def   pac   printf   

原文地址:https://www.cnblogs.com/wz-archer/p/12430084.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!