码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2016 数据的交换输出

时间:2020-03-06 20:22:46      阅读:60      评论:0      收藏:0      [点我收藏+]

标签:code   tput   输入   esc   int   swap   eof   表示   ios   

Problem Description

输入n(n<100)个数,找出其中最小的数,将它与最前面的数交换后输出这些数。

Input

输入数据有多组,每组占一行,每行的开始是一个整数n,表示这个测试实例的数值的个数,跟着就是n个整数。n=0表示输入的结束,不做处理。

Output

对于每组输入数据,输出交换后的数列,每组输出占一行。

Sample Input

4 2 1 3 4
5 5 4 3 2 1
0

Sample Output

1 2 3 4
1 4 3 2 5
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <cmath>
#include <map>

using namespace std;
typedef long long ll;

const double inf=1e20;
const int maxn=2e5+10;
const int mod=1e9+7;

int a[maxn];

int main(){
    int n;
    while(scanf("%d",&n)!=EOF){
        if(n==0)break;
        int j=0;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
            if(a[j]>a[i])j=i;
        }
        swap(a[0],a[j]);
        for(int i=0;i<n;i++){
            if(i==0)printf("%d",a[i]);
            else printf(" %d",a[i]);
        }
        printf("\n");
    }
    return 0;
}

补:仔细看看,这其实就是选择排序的第一次循环

hdu 2016 数据的交换输出

标签:code   tput   输入   esc   int   swap   eof   表示   ios   

原文地址:https://www.cnblogs.com/wz-archer/p/12428054.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!