码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2015 偶数求和

时间:2020-03-06 20:23:03      阅读:73      评论:0      收藏:0      [点我收藏+]

标签:要求   开始   输出   nbsp   printf   tor   ==   typedef   i++   

Problem Description

有一个长度为n(n<=100)的数列,该数列定义为从2开始的递增有序偶数,现在要求你按照顺序每m个数求出一个平均值,如果最后不足m个,则以实际数量求平均值。编程输出该平均值序列。

Input

输入数据有多组,每组占一行,包含两个正整数n和m,n和m的含义如上所述。

Output

对于每组输入数据,输出一个平均值序列,每组输出占一行。

Sample Input

3 2
4 2

Sample Output

3 6
3 7
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <cmath>
#include <map>

using namespace std;
typedef long long ll;

const double inf=1e20;
const int maxn=2e5+10;
const int mod=1e9+7;

int main(){
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF){
        int a=0;
        int num=0;
        int j=0;
        for(int i=1;i<n;i++){
            a+=2;
            num+=a;
            j++;
            if(i%m==0){
                printf("%d ",num/j);
                num=j=0;
            }
        }
        a+=2;
        num+=a;
        j++;
        printf("%d\n",num/j);
    }
    return 0;
}

 

hdu 2015 偶数求和

标签:要求   开始   输出   nbsp   printf   tor   ==   typedef   i++   

原文地址:https://www.cnblogs.com/wz-archer/p/12427993.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!