码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 4690 EBCDIC 模拟

时间:2014-11-04 21:13:09      阅读:287      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   color   ar   os   java   


把图片用ORC转化成文字,用vim录个宏很容易就可以字母们格式化.....

EBCDIC

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 102400/102400 K (Java/Others)
Total Submission(s): 811    Accepted Submission(s): 368


Problem Description
A mad scientist found an ancient message from an obsolete IBN System/360 mainframe. He believes that this message contains some very important secret about the Stein‘s Windows Project. The IBN System/360 mainframe uses Extended Binary Coded Decimal Interchange Code (EBCDIC). But his Artificial Intelligence Personal Computer (AIPC) only supports American Standard Code for Information Interchange (ASCII). To read the message, the mad scientist ask you, his assistant, to convert it from EBCDIC to ASCII.
Here is the EBCDIC table.
bubuko.com,布布扣
      
Here is the ASCII table.
bubuko.com,布布扣

 

Input
The input of this problem is a line of uppercase hexadecimal string of even length. Every two hexadecimal digits stands for a character in EBCDIC, for example, "88" stands for ‘h‘.
 

Output
Convert the input from EBCDIC to ASCII, and output it in the same format as the input.
 

Sample Input
C59340D7A2A840C3969587999696
 

Sample Output
456C2050737920436F6E67726F6F
Hint
E.html download 方便图中文字复制 http://pan.baidu.com/share/link?shareid=453447595&uk=352484775
 

Author
Zejun Wu (watashi)
 

Source
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <map>

using namespace std;

map<string,int> mp;

string EBCDIC[10000]=
{"NUL","SOH","STX","ETX","  ","HT","  ","DEL","  ","  ","  ","VT","FF","CR","SO","SI",
"DLE","DC1","DC2","DC3","  ","  ","BS","  ","CAN","EM","  ","  ","IFS","IGS","IRS","IUS ITB",
"  ","  ","  ","  ","  ","LF","ETB","ESC","  ","  ","  ","  ","  ","ENQ","ACK","BEL",
"  ","  ","SYN","  ","  ","  ","  ","EOT","  ","  ","  ","  ","DC4","NAK","  ","SUB",
"SP","  ","  ","  ","  ","  ","  ","  ","  ","  ","  ",".","<","(","+","|",
"&","  ","  ","  ","  ","  ","  ","  ","  ","  ","!","$","*",")",";","  ",
"-","/","  ","  ","  ","  ","  ","  ","  ","  ","  ",",","%","_",">","?",
"  ","  ","  ","  ","  ","  ","  ","  ","  ","`",":","#","@","'","=","\"",
"  ","a","b","c","d","e","f","g","h","i","  ","  ","  ","  ","  ","  ",
"  ","j","k","l","m","n","o","p","q","r","  ","  ","  ","  ","  ","  ",
"  ","~","s","t","u","v","w","x","y","z","  ","  ","  ","  ","  ","  ",
"^","  ","  ","  ","  ","  ","  ","  ","  ","  ","[","]","  ","  ","  ","  ",
"{","A","B","C","D","E","F","G","H","I","  ","  ","  ","  ","  ","  ",
"}","J","K","L","M","N","O","P","Q","R","  ","  ","  ","  ","  ","  ",
"\\","  ","S","T","U","V","W","X","Y","Z","  ","  ","  ","  ","  ","  ",
"0","1","2","3","4","5","6","7","8","9","  ","  ","  ","  ","  ","  "};

string ASC[10000]=
{
"NUL","SOH","STX","ETX","EOT","ENQ","ACK","BEL","BS","HT","LF","VT","FF","CR","SO","SI",
"DLE","DC1","DC2","DC3","DC4","NAK","SYN","ETB","CAN","EM","SUB","ESC","IFS","IGS","IRS","IUS ITB",
"SP","!","\"","#","$","%","&","'","(",")","*","+",",","-",".","/",
"0","1","2","3","4","5","6","7","8","9",":",";","<","=",">","?",
"@","A","B","C","D","E","F","G","H","I","J","K","L","M","N","O",
"P","Q","R","S","T","U","V","W","X","Y","Z","[","\\","]","^","_",
"`","a","b","c","d","e","f","g","h","i","j","k","l","m","n","o",
"p","q","r","s","t","u","v","w","x","y","z","{","|","}","~","DEL"
};

void init()
{
    for(int i=0;i<8;i++)
    {
        for(int j=0;j<16;j++)
        {
            mp[ASC[i*16+j]]=i*16+j;
        }
    }
}

int num(char c)
{
    if(c>='0'&&c<='9')
        return c-'0';
    return c-'A'+10;
}

char CHAR(int x)
{
    if(x<=9) return x+'0';
    return x-10+'A';
}

int main()
{
    string READ;
    init();
    while(cin>>READ)
    {
        for(int i=0,sz=READ.size();i<sz;i+=2)
        {
            int c1=num(READ[i]),c2=num(READ[i+1]);
            string ck=EBCDIC[c1*16+c2];
            int id=mp[ck];
            printf("%c%c",CHAR(id/16),CHAR(id%16));
        }
        putchar(10);
    }
    return 0;
}



HDOJ 4690 EBCDIC 模拟

标签:des   style   blog   http   io   color   ar   os   java   

原文地址:http://blog.csdn.net/ck_boss/article/details/40791263

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!