码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2026 首字母变大写

时间:2020-03-08 16:02:27      阅读:51      评论:0      收藏:0      [点我收藏+]

标签:string   包含   clu   col   span   英文   cstring   out   inpu   

Problem Description

输入一个英文句子,将每个单词的第一个字母改成大写字母。

Input

输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。

Output

请输出按照要求改写后的英文句子。

Sample Input

i like acm
i want to get an accepted

Sample Output

I Like Acm
I Want To Get An Accepted
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <cmath>
#include <map>

using namespace std;
typedef long long ll;

const double inf=1e20;
const int maxn=2e5+10;
const int mod=1e9+7;

char a[maxn];

int main(){
    while(gets(a)){
        int len=strlen(a);
        for(int i=1;i<len;i++){
            if(a[i]<=z&&a[i]>=a&&a[i-1]== ){
                a[i]-=a;
                a[i]+=A;
            }
        }
        if(a[0]<=z&&a[0]>=a){
            a[0]-=a;
            a[0]+=A;
        }
        puts(a);
    }
    return 0;
}

 

hdu 2026 首字母变大写

标签:string   包含   clu   col   span   英文   cstring   out   inpu   

原文地址:https://www.cnblogs.com/wz-archer/p/12442738.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!