码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2035 人见人爱A^B

时间:2020-03-08 19:31:49      阅读:39      评论:0      收藏:0      [点我收藏+]

标签:输入数据   col   title   map   ons   using   stream   tput   实例   

Problem Description

求A^B的最后三位数表示的整数。
说明:A^B的含义是“A的B次方”

Input

输入数据包含多个测试实例,每个实例占一行,由两个正整数A和B组成(1<=A,B<=10000),如果A=0, B=0,则表示输入数据的结束,不做处理。

Output

对于每个测试实例,请输出A^B的最后三位表示的整数,每个输出占一行。

Sample Input

2 3
12 6
6789 10000
0 0

Sample Output

8
984
1
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <cmath>
#include <map>

using namespace std;
typedef long long ll;

const double inf=1e20;
const int maxn=100+10;
const int mod=1e9+7;

int main(){
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF){
        if(n==m&&m==0)break;
        int num=1;
        for(int i=0;i<m;i++){
            num*=n;
            num%=1000;
        }
        printf("%d\n",num);
    }
    return 0;
}

 

hdu 2035 人见人爱A^B

标签:输入数据   col   title   map   ons   using   stream   tput   实例   

原文地址:https://www.cnblogs.com/wz-archer/p/12444187.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!