码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2032 杨辉三角

时间:2020-03-08 19:49:07      阅读:46      评论:0      收藏:0      [点我收藏+]

标签:++   定义   namespace   using   main   math   ios   str   ==   

Problem Description
还记得中学时候学过的杨辉三角吗?具体的定义这里不再描述,你可以参考以下的图形:
1
1 1
1 2 1
1 3 3 1
1 4 6 4 1
1 5 10 10 5 1
Input
输入数据包含多个测试实例,每个测试实例的输入只包含一个正整数n(1<=n<=30),表示将要输出的杨辉三角的层数。
Output
对应于每一个输入,请输出相应层数的杨辉三角,每一层的整数之间用一个空格隔开,每一个杨辉三角后面加一个空行。
Sample Input
2 3
Sample Output
1
1 1
 
 
1
 
1 1
1 2 1
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <cmath>
#include <map>

using namespace std;
typedef long long ll;

const double inf=1e20;
const int maxn=100+10;
const int mod=1e9+7;

int n,m;

int a[maxn][maxn];

int main(){
    for(int i=0;i<55;i++){
        for(int j=0;j<55;j++){
            if(j==0||j==i)a[i][j]=1;
            else{
                a[i][j]=a[i-1][j-1]+a[i-1][j];
            }
        }
    }
    int n;
    while(scanf("%d",&n)!=EOF){
        for(int i=0;i<n;i++){
            for(int j=0;j<=i;j++){
                if(j==0)printf("%d",a[i][j]);
                else printf(" %d",a[i][j]);
            }
            printf("\n");
        }
        printf("\n");
    }
    
    return 0;
}

 

 

hdu 2032 杨辉三角

标签:++   定义   namespace   using   main   math   ios   str   ==   

原文地址:https://www.cnblogs.com/wz-archer/p/12444052.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!