码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2034 人见人爱A-B

时间:2020-03-08 20:23:56      阅读:73      评论:0      收藏:0      [点我收藏+]

标签:行数据   pre   max   clu   提醒   元素   map   can   题目   

Problem Description

参加过上个月月赛的同学一定还记得其中的一个最简单的题目,就是{A}+{B},那个题目求的是两个集合的并集,今天我们这个A-B求的是两个集合的差,就是做集合的减法运算。(当然,大家都知道集合的定义,就是同一个集合中不会有两个相同的元素,这里还是提醒大家一下)
呵呵,很简单吧?

Input

每组输入数据占1行,每行数据的开始是2个整数n(0<=n<=100)和m(0<=m<=100),分别表示集合A和集合B的元素个数,然后紧跟着n+m个元素,前面n个元素属于集合A,其余的属于集合B. 每个元素为不超出int范围的整数,元素之间有一个空格隔开.
如果n=0并且m=0表示输入的结束,不做处理。

Output

针对每组数据输出一行数据,表示A-B的结果,如果结果为空集合,则输出“NULL”,否则从小到大输出结果,为了简化问题,每个元素后面跟一个空格.

Sample Input

3 3 1 2 3 1 4 7
3 7 2 5 8 2 3 4 5 6 7 8
0 0

Sample Output

2 3
NULL
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <cmath>
#include <map>

using namespace std;
typedef long long ll;

const double inf=1e20;
const int maxn=100+10;
const int mod=1e9+7;

int a[maxn],b[maxn],c[maxn];

int main(){
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF){
        if(n==m&&m==0)break;
        for(int i=0;i<n;i++){
            scanf("%d",&a[i]);
        }
        for(int i=0;i<m;i++){
            scanf("%d",&b[i]);
        }
        int k=0;
        for(int i=0;i<n;i++){
            int o=1;
            for(int j=0;j<m;j++){
                if(a[i]==b[j])o=0;
            }
            if(o){
                c[k++]=a[i];
            }
        }
        if(k==0)printf("NULL");
        else{
            sort(c,c+k);
            printf("%d ",c[0]);
            for(int i=1;i<k;i++){
                if(c[i]!=c[i-1]) printf("%d ",c[i]);
            }
            
        }
        printf("\n");
    }
    return 0;
}

 

hdu 2034 人见人爱A-B

标签:行数据   pre   max   clu   提醒   元素   map   can   题目   

原文地址:https://www.cnblogs.com/wz-archer/p/12444158.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!