标签:算法 poj 编程 c++
Just the Facts
Time Limit: 1000MS |
|
Memory Limit: 65536K |
Total Submissions: 8781 |
|
Accepted: 4659 |
Description
The expression N!, read as "N factorial," denotes the product of the first N positive integers, where N is nonnegative. So, for example,
N N!
0 1
1 1
2 2
3 6
4 24
5 120
10 3628800
For this problem, you are to write a program that can compute the last non-zero digit of any factorial for (0 <= N <= 10000). For example, if your program is asked to compute the last nonzero digit of 5!, your program should produce "2" because 5! = 120, and
2 is the last nonzero digit of 120.
Input
Input to the program is a series of nonnegative integers not exceeding 10000, each on its own line with no other letters, digits or spaces. For each integer N, you should read the value and compute the last nonzero digit of N!.
Output
For each integer input, the program should print exactly one line of output. Each line of output should contain the value N, right-justified in columns 1 through 5 with leading blanks, not leading zeroes. Columns 6 - 9 must contain " -> " (space hyphen greater
space). Column 10 must contain the single last non-zero digit of N!.
Sample Input
1
2
26
125
3125
9999
Sample Output
1 -> 1
2 -> 2
26 -> 4
125 -> 8
3125 -> 2
9999 -> 8
题意:求阶乘n!的最后一个不为0的数字;
解题思路:直接模拟打表,注意每次做乘法得到的值需要模除100000;最后输出格式需要注意;
#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
#define MAX 10000
int main(){
int n,a[MAX+5];
int mul=1;
memset(a,0,sizeof(a));
for (int i=1;i<MAX;i++){
mul*=i;
while (mul%10==0)
mul/=10;
mul%=100000;
a[i]=mul%10;
}
while (cin>>n){
printf("%5d -> %d\n",n,a[n]);
}
return 0;
}
poj 1604 Just the Facts
标签:算法 poj 编程 c++
原文地址:http://blog.csdn.net/codeforcer/article/details/40794487