码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2051 Bitset(进制转换)

时间:2020-03-09 20:52:34      阅读:49      评论:0      收藏:0      [点我收藏+]

标签:mes   NPU   problem   space   pac   pre   bsp   int   bit   

Problem Description

Give you a number on base ten,you should output it on base two.(0 < n < 1000)

Input

For each case there is a postive number n on base ten, end of file.

Output

For each case output a number on base two.

Sample Input

1
2
3

Sample Output

1
10
11
解:和hdu 2031 是一个题,代码直接拿过来用一下。
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <cmath>
#include <map>

using namespace std;
typedef long long ll;

const double inf=1e20;
const int maxn=2e5+10;
const int mod=1e9+7;

int n,m;

void f(int x){
    if(x/m!=0){
        f(x/m);
    }
    int xx=x%m;
    if(xx<10)
        printf("%d",xx);
    else if(xx>=10)printf("%c",xx-10+A);
}

int main(){
    m=2;
    while(scanf("%d",&n)!=EOF){
        if(n<0){
            printf("-");
            n=-n;
        }
        f(n);
        printf("\n");
    }
    return 0;
}

 

hdu 2051 Bitset(进制转换)

标签:mes   NPU   problem   space   pac   pre   bsp   int   bit   

原文地址:https://www.cnblogs.com/wz-archer/p/12450816.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!