码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2091 空心三角形

时间:2020-03-10 11:49:36      阅读:44      评论:0      收藏:0      [点我收藏+]

标签:通过   string   bsp   nbsp   过程   tchar   return   整数   class   

Problem Description
把一个字符三角形掏空,就能节省材料成本,减轻重量,但关键是为了追求另一种视觉效果。在设计的过程中,需要给出各种花纹的材料和大小尺寸的三角形样板,通过电脑临时做出来,以便看看效果。
Input
每行包含一个字符和一个整数n(0<n<41),不同的字符表示不同的花纹,整数n表示等腰三角形的高。显然其底边长为2n-1。如果遇到@字符,则表示所做出来的样板三角形已经够了。
Output
每个样板三角形之间应空上一行,三角形的中间为空。显然行末没有多余的空格。
Sample Input
X 2 A 7 @
Sample Output
  X
XXX
 
           A
           A    A
         A        A
       A            A
     A                 A
  A                      A
AAAAAAAAAAAAA
 
#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <cmath>
#include <queue>
#include <deque>
#include <cmath>
#include <map>

using namespace std;
typedef long long ll;

const double inf=1e20;
const int maxn=1e5+10;
const int mod=1e9+7;

int main(){
    char a;
    int n;
    int o=0;
    while(scanf("%c",&a)!=EOF){
        if(a==@)break;
        getchar();
        scanf("%d",&n);
        getchar();
        if(o)printf("\n");
        o=1;
        int k=-1;
        for(int i=1;i<n;i++){
            for(int j=n-i;j>0;j--)printf(" ");
            printf("%c",a);
            for(int j=0;j<k;j++)printf(" ");
            k+=2;
            if(i!=1)printf("%c",a);
            printf("\n");
        }
        for(int i=0;i<2*n-1;i++)printf("%c",a);
        printf("\n");
    }
    return 0;
}

 

hdu 2091 空心三角形

标签:通过   string   bsp   nbsp   过程   tchar   return   整数   class   

原文地址:https://www.cnblogs.com/wz-archer/p/12454306.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!