码迷,mamicode.com
首页 > 其他好文 > 详细

POJ - 2689 Prime Distance(大区间素数筛选)

时间:2014-11-05 00:33:10      阅读:200      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   color   ar   os   for   

Description

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers. 
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source


题意:输出区间[l, r]中,差最大和最小的两对素数。

思路:因为范围很大,区间相对较小,所以我们先筛选出2^16范围内的素数,然后通过小的区间去删除大区间的合数(每个合数都能通过素数相乘得到)。最后遍历

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
typedef long long ll;
using namespace std;
const int INF = 1<<30;
const int inf = 60000;
const int maxn = 1000005;

int prime[maxn], vis[maxn], cnt;

void init() {
	cnt = 0;
	for (ll i = 2; i < inf; i++) 
		if (!vis[i]) {
			prime[cnt++] = i;
			for (ll j = i*i; j < inf; j += i)
				vis[j] = 1;
		}
}

int isprime[maxn], a[maxn], c;

int main() {
	int l, r;
	init();
	while (scanf("%d%d", &l, &r) != EOF) {
		memset(isprime, 1, sizeof(isprime));
		if (l == 1) l = 2;
		for (int i = 0; i < cnt && (ll)prime[i]*prime[i] <= r; i++) {
			int s = l / prime[i] + (l % prime[i] > 0);
			if (s == 1) s = 2;
			for (int j = s; (ll)j*prime[i] <= r; j++) 
				if ((ll)j*prime[i] >= l) 
					isprime[j*prime[i]-l] = 0;
		}
		c = 0;
		for (int i = 0; i <= r-l; i++) 
			if (isprime[i])
				a[c++] = i + l;
		if (c < 2) {
			printf("There are no adjacent primes.\n");
			continue;
		}
		else {
			int x1 = 0, x2 = 0, y1 = 0, y2 = INF;	
			for (int i = 1; i < c; i++) {
				if (a[i] - a[i-1] > x2 - x1) {
					x1 = a[i-1];
					x2 = a[i];
				}
				if (a[i] - a[i-1] < y2 - y1) {
					y1 = a[i-1];
					y2 = a[i];
				}
			}
			printf("%d,%d are closest, %d,%d are most distant.\n", y1, y2, x1, x2);
		}
	}
	return 0;
}



POJ - 2689 Prime Distance(大区间素数筛选)

标签:des   style   blog   http   io   color   ar   os   for   

原文地址:http://blog.csdn.net/u011345136/article/details/40796987

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!