码迷,mamicode.com
首页 > 其他好文 > 详细

poj2096 Collecting Bugs 概率dp

时间:2014-11-05 08:07:15      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:des   blog   io   ar   os   for   sp   strong   div   

Collecting Bugs
Time Limit: 10000MS   Memory Limit: 64000K
Total Submissions: 2745   Accepted: 1345
Case Time Limit: 2000MS   Special Judge

Description

Ivan is fond of collecting. Unlike other people who collect post stamps, coins or other material stuff, he collects software bugs. When Ivan gets a new program, he classifies all possible bugs into n categories. Each day he discovers exactly one bug in the program and adds information about it and its category into a spreadsheet. When he finds bugs in all bug categories, he calls the program disgusting, publishes this spreadsheet on his home page, and forgets completely about the program. 
Two companies, Macrosoft and Microhard are in tight competition. Microhard wants to decrease sales of one Macrosoft program. They hire Ivan to prove that the program in question is disgusting. However, Ivan has a complicated problem. This new program has s subcomponents, and finding bugs of all types in each subcomponent would take too long before the target could be reached. So Ivan and Microhard agreed to use a simpler criteria --- Ivan should find at least one bug in each subsystem and at least one bug of each category. 
Macrosoft knows about these plans and it wants to estimate the time that is required for Ivan to call its program disgusting. It‘s important because the company releases a new version soon, so it can correct its plans and release it quicker. Nobody would be interested in Ivan‘s opinion about the reliability of the obsolete version. 
A bug found in the program can be of any category with equal probability. Similarly, the bug can be found in any given subsystem with equal probability. Any particular bug cannot belong to two different categories or happen simultaneously in two different subsystems. The number of bugs in the program is almost infinite, so the probability of finding a new bug of some category in some subsystem does not reduce after finding any number of bugs of that category in that subsystem. 
Find an average time (in days of Ivan‘s work) required to name the program disgusting.

Input

Input file contains two integer numbers, n and s (0 < n, s <= 1 000).

Output

Output the expectation of the Ivan‘s working days needed to call the program disgusting, accurate to 4 digits after the decimal point.

Sample Input

1 2

Sample Output

3.0000

一开始列出公式不知道干什么,但是实际上,从n,s的状态向0,0状态逆着递推,当n,s状态时,一步也不需要移动,否则则

dp[i][j]=1+dp[i+1][j]*j*(n-i)/n/s+dp[i][j+1]*i*(s-j)/n/s+dp[i+1][j+1]*(s-j)*(n-i)/n/s+dp[i][j]*i*j/n/s;

因为此时后面的状态已经不会影响到前面的状态,所以直接除以即可

#include <cstdio>
#include <cstring>
using namespace std;
int n,s;
double dp[1001][1001];
int main(){
    while(scanf("%d%d",&n,&s)==2){
        memset(dp,0,sizeof(dp));
        for(int i=n;i>=0;i--){
            for(int j=s;j>=0;j--){
              if(i==n&&j==s)continue;
              dp[i][j]=1+dp[i+1][j]*j*(n-i)/n/s+dp[i][j+1]*i*(s-j)/n/s+dp[i+1][j+1]*(s-j)*(n-i)/n/s;
                double p=1-(double)i*j/n/s;
                dp[i][j]/=p;
            }
        }
        printf("%.4f\n",dp[0][0]);
    }
}

  

poj2096 Collecting Bugs 概率dp

标签:des   blog   io   ar   os   for   sp   strong   div   

原文地址:http://www.cnblogs.com/xuesu/p/4075319.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!