码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3619 Speed Reading

时间:2014-11-05 14:54:21      阅读:171      评论:0      收藏:0      [点我收藏+]

标签:算法   poj   编程   c++   

Speed Reading
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8431   Accepted: 3935

Description

All K (1 ≤ K ≤ 1,000) of the cows are participating in Farmer John‘s annual reading contest. The competition consists of reading a single book with N (1 ≤ N ≤ 100,000) pages as fast as possible while understanding it.

Cow i has a reading speed Si (1 ≤ Si ≤ 100) pages per minute, a maximum consecutive reading time Ti (1 ≤ Ti ≤ 100) minutes, and a minimum rest time Ri (1 ≤ Ri ≤ 100) minutes. The cow can read at a rate ofSi pages per minute, but only for Ti minutes at a time. After she stops reading to rest, she must rest for Ri minutes before commencing reading again.

Determine the number of minutes (rounded up to the nearest full minute) that it will take for each cow to read the book.

Input

* Line 1: Two space-separated integers: N and K
* Lines 2..K+1: Line i+1 contains three space-separated integers: Si , Ti , and Ri

Output

* Lines 1..K: Line i should indicate how many minutes (rounded up to the nearest full minute) are required for cow i to read the whole book.

Sample Input

10 3
2 4 1
6 1 5
3 3 3

Sample Output

6
7
7

题意:牛读一个厚度为n的书,每秒可以读s页,可以连续读t秒,不过读完t秒后必需要休息r秒的时间,求牛读完这本书所需的时间;

#include <iostream>
using namespace std;
int main(){
	int n,k,s,t,r;
	cin>>n>>k;
	for (int i=0;i<k;i++){
		cin>>s>>t>>r;
		int page=n;
		int time=0;
		while (page>s*t){
			time=time+t+r;
			page-=s*t;
		}
		time+=page/s;
		if (page%s)
			time++;
		cout<<time<<endl;
	}
	return 0;
}



poj 3619 Speed Reading

标签:算法   poj   编程   c++   

原文地址:http://blog.csdn.net/codeforcer/article/details/40821761

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!