标签:contain tle span font ber BMI mes return find
Dragon Balls
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10628 Accepted Submission(s): 3802
Problem Description
Five
hundred years later, the number of dragon balls will increase
unexpectedly, so it‘s too difficult for Monkey King(WuKong) to gather
all of the dragon balls together.
His
country has N cities and there are exactly N dragon balls in the world.
At first, for the ith dragon ball, the sacred dragon will puts it in
the ith city. Through long years, some cities‘ dragon ball(s) would be
transported to other cities. To save physical strength WuKong plans to
take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.
Every time WuKong will collect the information of one dragon ball,
he will ask you the information of that ball. You must tell him which
city the ball is located and how many dragon balls are there in that
city, you also need to tell him how many times the ball has been
transported so far.
Input
The first line of the input is a single positive integer T(0 < T <= 100).
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
T
A B : All the dragon balls which are in the same city with A have been
transported to the city the Bth ball in. You can assume that the two
cities are different.
Q A : WuKong want to know X (the id of the
city Ath ball is in), Y (the count of balls in Xth city) and Z (the
tranporting times of the Ath ball). (1 <= A, B <= N)
Output
For
each test case, output the test case number formated as sample output.
Then for each query, output a line with three integers X Y Z saparated
by a blank space.
Sample Input
2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1
Sample Output
Case 1:
2 3 0
Case 2:
2 2 1
3 3 2
题目大意与分析
n个龙珠,q次操作 T操作是将a所在的堆移到b堆上 Q操作是问a所在的堆是哪一个、堆上有多少龙珠以及a目前为止移动了多少次
带权并查集,在find函数压缩路径的时候修改step值,子节点的移动次数等于子节点移动次数+父节点移动次数(因为在合并的时候修改的是根节点的次数,所以在find函数中要修正子节点的移动次数)
#include<bits/stdc++.h>
using namespace std;
int s[10005],n,m,sum[10005],step[10005],t,k=0;
char C[2];
int findf(int x)
{
if(s[x]==x)
{
return x;
}
else
{
int temp=s[x];
s[x]=findf(s[x]);
step[x]+=step[temp]; //修正步数
return s[x];
}
}
void hebing(int x,int y)
{
int fx=findf(x);
int fy=findf(y);
if(fx!=fy)
{
s[fx]=fy; //x移到y上 所以修改s[fx]
step[fx]++;
sum[fy]+=sum[fx];
}
}
int main()
{
scanf("%d",&t);
ios::sync_with_stdio(false);
while(t--)
{
scanf("%d%d",&n,&m);
k++;
printf("Case %d:\n",k);
for(int i=1;i<=n;i++)
{
s[i]=i;
sum[i]=1;
step[i]=0;
}
while(m--)
{
scanf("%s",&C);
if(C[0]==‘T‘)
{
int a,b;
scanf("%d%d",&a,&b);
hebing(a,b);
}
else
{
int a;
scanf("%d",&a);
int fa=findf(a);
printf("%d %d %d\n",fa,sum[fa],step[a]);
}
}
}
}
HDU3635 Dragon Balls (带权并查集)
标签:contain tle span font ber BMI mes return find
原文地址:https://www.cnblogs.com/dyhaohaoxuexi/p/12557160.html