码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1979 Red and Black

时间:2014-11-05 17:16:24      阅读:161      评论:0      收藏:0      [点我收藏+]

标签:poj1979

Red and Black
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 23001   Accepted: 12407

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

Source

#include <stdio.h>
#include <string.h>

#define maxn 30

char G[maxn][maxn];
int n, m, X, Y, sum; // n rows m columns and start position
const int mov[][2] = {0, 1, 0, -1, 1, 0, -1, 0};

void getMap() {
    int i, j;
    for(i = 0; i < n; ++i) {
        scanf("%s", G[i]);
        for(j = 0; G[i][j]; ++j)
            if(G[i][j] == '@') {
                X = i; Y = j;
            }
    }
}

bool check(int x, int y) {
    if(x < 0 || y < 0 || x >= n || y >= m)
        return false;
    return G[x][y] == '.';
}

void DFS(int x, int y) {
    G[x][y] = '#'; ++sum;
    int i, j, xa, ya;
    for(i = 0; i < 4; ++i) {
        xa = x + mov[i][0];
        ya = y + mov[i][1];
        if(check(xa, ya))
            DFS(xa, ya);
    }
}

int main() {
    // freopen("stdin.txt", "r", stdin);
    while(scanf("%d%d", &m, &n), m | n) {
        getMap();
        sum = 0;
        DFS(X, Y);
        printf("%d\n", sum);
    }
    return 0;
}


POJ1979 Red and Black

标签:poj1979

原文地址:http://blog.csdn.net/chang_mu/article/details/40825399

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!