码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5095 Linearization of the kernel functions in SVM(模拟)

时间:2014-11-05 17:21:04      阅读:199      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   color   ar   os   java   for   sp   

Linearization of the kernel functions in SVM

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 206    Accepted Submission(s): 109


Problem Description
SVM(Support Vector Machine)is an important classification tool, which has a wide range of applications in cluster analysis, community division and so on. SVM The kernel functions used in SVM have many forms. Here we only discuss the function of the form f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j. By introducing new variables p, q, r, u, v, w, the linearization of the function f(x,y,z) is realized by setting the correspondence x^2 <-> p, y^2 <-> q, z^2 <-> r, xy <->u, yz <-> v, zx <-> w and the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j can be written as g(p,q,r,u,v,w,x,y,z) = ap + bq + cr + du + ev + fw + gx + hy + iz + j, which is a linear function with 9 variables.

Now your task is to write a program to change f into g.
 

Input
The input of the first line is an integer T, which is the number of test data (T<120). Then T data follows. For each data, there are 10 integer numbers on one line, which are the coefficients and constant a, b, c, d, e, f, g, h, i, j of the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j.
 

Output
For each input function, print its correspondent linear function with 9 variables in conventional way on one line.
 

Sample Input
2 0 46 3 4 -5 -22 -8 -32 24 27 2 31 -5 0 0 12 0 0 -49 12
 

Sample Output
46q+3r+4u-5v-22w-8x-32y+24z+27 2p+31q-5r+12w-49z+12
 


 有 -1 和 1 的情况 , 考虑清楚就ok了 。


#include <iostream>
#include <cstdio>
using namespace std;
const int maxn = 15 ;
const char ch[maxn] = {'p','q','r','u','v','w','x','y','z','j'};

int a[maxn];

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        for(int i=0; i<10; i++) scanf("%d",&a[i]);
        a[10]=99;
        int cnt=0;
        while(a[cnt]==0) cnt++;
        if(cnt==10)
        {
            cout<<"0"<<endl;
            continue;
        }

        if(cnt==9)  cout<<a[cnt];
        else
        {
            if(a[cnt]==1) cout<<ch[cnt];
            else if(a[cnt]==-1)  cout<<"-"<<ch[cnt];
            else  cout<<a[cnt]<<ch[cnt];
        }

        for(int i=cnt+1; i<10; i++)
        {
            if(a[i]==0)  continue;
            if(a[i]>0) cout<<"+";
            if(i==9)  cout<<a[i];
            else
            {
                if(a[i]==1) cout<<ch[i];
                else if(a[i]==-1)  cout<<"-"<<ch[i];
                else  cout<<a[i]<<ch[i];
            }
        }
        cout<<endl;
    }
    return 0;
}


hdu 5095 Linearization of the kernel functions in SVM(模拟)

标签:des   style   io   color   ar   os   java   for   sp   

原文地址:http://blog.csdn.net/u012596172/article/details/40824047

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!