码迷,mamicode.com
首页 > 其他好文 > 详细

HDoj 2028 Lowest Common Multiple Plus

时间:2020-03-28 13:09:44      阅读:71      评论:0      收藏:0      [点我收藏+]

标签:source   输入   ever   tom   malloc   auth   out   author   mode   

Problem Description
求n个数的最小公倍数。
 

 

Input
输入包含多个测试实例,每个测试实例的开始是一个正整数n,然后是n个正整数。
 

 

Output
为每组测试数据输出它们的最小公倍数,每个测试实例的输出占一行。你可以假设最后的输出是一个32位的整数。
 

 

Sample Input
2 4 6 3 2 5 7
 

 

Sample Output
12 70
 

 

Author
lcy
 

 

Source
 

 

Recommend
lcy   |   We have carefully selected several similar problems for you:  2032 2031 2029 2030 2035 
 
 
 
C语言代码如下:
#include<stdio.h>
#include<malloc.h>
int main()
{
    int n=0;
    int flag;
    int i,j;
    while(scanf("%d",&n)!=EOF)
    {
        int *a=(int *)malloc(sizeof(int)*n);
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(i=a[n-1];;i++)
        {
            flag=1;
            for(j=0;j<n;j++)
            {
                if(i%a[j]!=0)
                {
                    flag=0;
                    break;
                }
            }
            if(flag==1)
                break;
        }
        printf("%d\n",i);
    }
}

 

HDoj 2028 Lowest Common Multiple Plus

标签:source   输入   ever   tom   malloc   auth   out   author   mode   

原文地址:https://www.cnblogs.com/wzmm/p/12586736.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!