码迷,mamicode.com
首页 > 其他好文 > 详细

1089 Insert or Merge

时间:2020-04-03 13:46:45      阅读:70      评论:0      收藏:0      [点我收藏+]

标签:sum   rate   answer   win   sed   +=   oca   second   into   

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Merge sort works as follows: Divide the unsorted list into N sublists, each containing 1 element (a list of 1 element is considered sorted). Then repeatedly merge two adjacent sublists to produce new sorted sublists until there is only 1 sublist remaining.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Merge Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resuling sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0
 

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0
 

Sample Input 2:

10
3 1 2 8 7 5 9 4 0 6
1 3 2 8 5 7 4 9 0 6
 

Sample Output 2:

Merge Sort
1 2 3 8 4 5 7 9 0 6

题意:

 

 

Code:

#include<iostream>
#include<vector>
#include<algorithm>

using namespace std;

void Merge(vector<int> &p, vector<int> &t, int l, int r, int Rend) {
    int Lend = r - 1;
    int prt = l;
    while (l <= Lend && r <= Rend) {
        if (p[l] < p[r]) t[prt++] = p[l++];
        if (p[r] < p[l]) t[prt++] = p[r++];
    }
    while (l <= Lend) t[prt++] = p[l++];
    while (r <= Rend) t[prt++] = p[r++];
    int len = 2 * (Rend - Lend);
    for (int i = 0; i < len; ++i, Rend--) p[Rend] = t[Rend];
}

int main() {
    int n;
    cin >> n;

    vector<int> init(n);
    vector<int> part(n);
    vector<int> temp(n);

    int t, p, q;
    for (int i = 0; i < n; ++i) {
        cin >> t;
        init[i] = t;
    }
    for (int i = 0; i < n; ++i) {
        cin >> t;
        part[i] = t;
    }
    p = 1;
    while (p < n && part[p] > part[p-1]) ++p;
    p++;
    q = p;
    while (q < n && part[q] == init[q]) ++q;

    if (q == n) {
        cout << "Insertion Sort" << endl;
        sort(part.begin(), part.begin()+p);
        cout << part[0];
        for (int i = 1; i < n; ++i) cout << " " << part[i];
    } else {
        cout << "Merge Sort" << endl;
        int j, k;
        bool flag = false;
        for (j = 1; j < n; j *= 2) {
            k = j - 1;
            while (k + 1 < n) {
                if (part[k] < part[k+1]) k += 2 * j;
                else { flag = true; break; }
            }
            if (flag) break;
        }
        for (k = 0; k <= n-2*j; k += 2*j) {
            Merge(part, temp, k, k+j, k+2*j-1);
        }
        if (k + j < n)
            Merge(part, temp, k, k+j, n);

        cout << part[0];
        for (int i = 1; i < n; ++i) cout << " " << part[i];
    }
        
    
    cout << endl;

    return 0;
}

  

骗了15分。


 

1089 Insert or Merge

标签:sum   rate   answer   win   sed   +=   oca   second   into   

原文地址:https://www.cnblogs.com/ruruozhenhao/p/12625859.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!