码迷,mamicode.com
首页 > 其他好文 > 详细

回文子串

时间:2020-04-04 20:25:15      阅读:61      评论:0      收藏:0      [点我收藏+]

标签:字符   class   优先   i++   cstring   std   检索   ace   namespace   

回文子串

描述

给定一个字符串,输出所有长度至少为2的回文子串。

回文子串即从左往右输出和从右往左输出结果是一样的字符串,比如:abba,cccdeedccc都是回文字符串

输入

一个字符串,由字母或数字组成。长度500以内。

输出

输出所有的回文子串,每个子串一行。
子串长度小的优先输出,若长度相等,则出现位置靠左的优先输出。

样例输入

123321125775165561

样例输出

33
11
77
55
2332
2112
5775
6556
123321
165561

代码

#include <iostream>
#include <cstring>
using namespace std;

int main() {
	char str[501];
	cin >> str;
	int len = strlen(str);
	int j = 2;
	for (int i = 0; i <= len; i++) {
		if (j > len) break;
		if (i == len && j == len) break;
		if (i == len && j != len) i = 0, j++;
		int ii = 0;
		for (; ii < j / 2; ++ii) {
			if (str[i + ii] != str[i + j - 1 - ii]) break;
		}
		if (ii == j / 2) {
			for (int k = 0; k < j; ++k) cout << str[i + k];
			cout << endl;
		}
	}
	return 0;
}

思路分析

其实这个题的中下难度,暴力检索匹配就行

回文子串

标签:字符   class   优先   i++   cstring   std   检索   ace   namespace   

原文地址:https://www.cnblogs.com/desperate-me/p/12633663.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!