码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3276 Face The Right Way 【尺取法】

时间:2014-11-06 17:32:23      阅读:212      评论:0      收藏:0      [点我收藏+]

标签:poj3276

Face The Right Way
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 2721   Accepted: 1246

Description

Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than Kcows, e.g., at the either end of the line of cows). Each cow remains in the same *location* as before, but ends up facing the *opposite direction*. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

Input

Line 1: A single integer: N 
Lines 2..N+1: Line i+1 contains a single character, F or B, indicating whether cow i is facing forward or backward.

Output

Line 1: Two space-separated integers: K and M

Sample Input

7
B
B
F
B
F
B
B

Sample Output

3 3

Hint

For K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)

Source



/*
** Problem: POJ No.3276
** Running time: 297MS
** Complier: C++
** Author: Changmu
**
** 题意:N头牛排成一列1<=N<=5000。每头牛或者向前或者向后。为了让所有牛都
** 面向前方,农夫每次可以将K头连续的牛转向1<=K<=N,求操作的最少
** 次数M和对应的最小K。
** 
** 题解:由于交换区间翻转顺序对结果没影响,所以从左往右对于需要
** 翻转的牛进行反转,同时记录对该区间其他牛的影响即cal中的sum,
** 对于最后部分无法翻转的区间检查是否有反向牛,若有则方案失败。 
*/

#include <stdio.h>
#include <string.h>

#define maxn 5010

int cow[maxn], N, K, M; // 奶牛们的初始位置,0前1后
int tra[maxn]; // 是否翻转第i头牛,1翻

int cal(int k) { // 翻转顺序从左往右
    int ans = 0, i, sum = 0;
    for(i = 0; i + k <= N; ++i) {
        tra[i] = 0; // initialize
        if((sum + cow[i]) & 1) {
            tra[i] = 1; 
            ++ans;
        }
        sum += tra[i]; // 尺取法
        if(i - k + 1 >= 0)
            sum -= tra[i-k+1];
    }
    // 检查剩下的是否有反向奶牛
    for( ; i < N; ++i)
        if((sum + cow[i]) & 1)
            return -1;
        else if(i - k + 1 >= 0)
            sum -= tra[i-k+1];
    return ans;
}

int main() {
    char ch[2];
    int i, m, k;
    while(scanf("%d", &N) == 1) {
        for(i = 0; i < N; ++i) {
            scanf("%s", ch);
            if(ch[0] == 'B') cow[i] = 1;
            else cow[i] = 0;
        }
        M = N; K = 1;
        for(k = 1; k <= N; ++k) {
            m = cal(k);
            if(m >= 0 && m < M) {
                M = m; K = k;
            }
        }
        printf("%d %d\n", K, M);
    }
    return 0;
}


POJ3276 Face The Right Way 【尺取法】

标签:poj3276

原文地址:http://blog.csdn.net/chang_mu/article/details/40863659

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!