码迷,mamicode.com
首页 > 其他好文 > 详细

ZOJ-2091-Mean of Subsequence (反证法的运用!!)

时间:2014-11-06 17:40:21      阅读:162      评论:0      收藏:0      [点我收藏+]

标签:hdu   algorithm   c++   水题   贪心   

ZOJ Problem Set - 2091
Mean of Subsequence

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Given N numbers in a line, we can determine a continuous subsequence by giving its start position and its length.

PMH and Roy played a game the other day. Roy gives the start position first, then PMH gives the length. Roy wants the mean of the subsequence as large as possible, while PMH wants it as small as possible.

You are to calculate the best result Roy can get, assuming PMH is very clever.


Input

There are multiple testcases.

Each testcase begins with a line containing N only.

The following line contains N numbers, separated by spaces.


Output

For each testcase, you are to print the best mean of subsequece Roy can get, precise to 6 digit after decimal point.


Sample Input

10
2 10 4 6 5 10 10 2 3 2


Sample Output

5.777778



Author: SHI, Xiaohan
Source: ZOJ Monthly, March 2004

题意:其实就是找后几个数的平均值的最大值!! (贪心策略!要找对)

k=1,2,3……n ,记k以及k后面的数的平均值最大的那个k做maxk

一旦Roy选了这个maxk , PMH必定会将所选数字长度最大化

为什么呢??

用反证法证明:如果所选长度的最后一个数字不是最后一个数n,  而是maxk与n中间的某个数t

那么也就是说ave(maxk...t)<ave(maxk...n)

那么必有 ave(t+1...n)>ave(maxk...n)   说明t+1后面几个数的平均数最大 与题设矛盾


AC代码:

#include <stdio.h>

int str[10000];

int main()
{
    double ans, sum;
    int n, m, i;
    while(scanf("%d", &n) != EOF)
    {
        if(n == 0)
        {
            putchar(10);
            continue;
        }
        sum = 0;
        for(i = 0; i < n; i++)
        {
            scanf("%d", &str[i]);
            sum += str[i];
        }
        ans = sum / n;
        m = n;
        for(i = 0; i < n - 1; i++)
        {
            sum -= str[i];
            m--;
            if(sum / m >= ans)
                ans = sum / m;
        }
        printf("%.6lf\n",ans);
    }
    return 0;
}





ZOJ-2091-Mean of Subsequence (反证法的运用!!)

标签:hdu   algorithm   c++   水题   贪心   

原文地址:http://blog.csdn.net/u014355480/article/details/40862041

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!