码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5078 Revenge of LIS II(dp LIS)

时间:2014-11-06 21:57:19      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   color   ar   os   for   

Problem Description
In computer science, the longest increasing subsequence problem is to find a subsequence of a given sequence in which the subsequence‘s elements are in sorted order, lowest to highest, and in which the subsequence is as long as possible. This subsequence is not necessarily contiguous, or unique.
---Wikipedia

Today, LIS takes revenge on you, again. You mission is not calculating the length of longest increasing subsequence, but the length of the second longest increasing subsequence.
Two subsequence is different if and only they have different length, or have at least one different element index in the same place. And second longest increasing subsequence of sequence S indicates the second largest one while sorting all the increasing subsequences of S by its length.
 

Input
The first line contains a single integer T, indicating the number of test cases.

Each test case begins with an integer N, indicating the length of the sequence. Then N integer Ai follows, indicating the sequence.

[Technical Specification]
1. 1 <= T <= 100
2. 2 <= N <= 1000
3. 1 <= Ai <= 1 000 000 000
 

Output
For each test case, output the length of the second longest increasing subsequence.
 

Sample Input
3 2 1 1 4 1 2 3 4 5 1 1 2 2 2
 

Sample Output
1 3 2
Hint
For the first sequence, there are two increasing subsequence: [1], [1]. So the length of the second longest increasing subsequence is also 1, same with the length of LIS.
 

Source
 

Recommend

参考链接:http://blog.csdn.net/acvay/article/details/40686171


比赛时没有读懂题目开始做结果被hack了,后来一直想nlogn的方法,无果,以后应该会想出来,以后再贴那种方法代码


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>

#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
using namespace std;
#define N 10005

int a[N],dp[N],c[N];
int n;

int main()
{
	int i,j,t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);

        int ans=0;
        for(i=1;i<=n;i++)
		{
			dp[i]=1;
			c[i]=1;
			for(j=1;j<i;j++)
			{
			   if(a[i]<=a[j]) continue;

			   if(dp[j]+1>dp[i])
			   {
			   	 dp[i]=dp[j]+1;
			   	 c[i]=c[j];
			   }
			   else
				if(dp[j]+1==dp[i])
				 c[i]=2;
			}
			if(dp[i]>ans)
				ans=dp[i];
		}
		j=0;
		for(i=1;i<=n;i++)
			if(dp[i]==ans)
		{
			j+=c[i];
			if(j>1)
				break;
		}
		if(j>1)
			printf("%d\n",ans);
		else
			printf("%d\n",ans-1);
	}
	return 0;
}




HDU 5078 Revenge of LIS II(dp LIS)

标签:des   style   blog   http   io   color   ar   os   for   

原文地址:http://blog.csdn.net/u014737310/article/details/40867627

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!