码迷,mamicode.com
首页 > 其他好文 > 详细

hdu4122 Alice's mooncake shop 单调队列

时间:2014-11-06 21:58:01      阅读:240      评论:0      收藏:0      [点我收藏+]

标签:hdu

http://acm.hdu.edu.cn/showproblem.php?pid=4122

Alice‘s mooncake shop

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2908    Accepted Submission(s): 744


Problem Description
The Mid-Autumn Festival, also known as the Moon Festival or Zhongqiu Festival is a popular harvest festival celebrated by Chinese people, dating back over 3,000 years to moon worship in China‘s Shang Dynasty. The Zhongqiu Festival is held on the 15th day of the eighth month in the Chinese calendar, which is in September or early October in the Gregorian calendar. It is a date that parallels the autumnal equinox of the solar calendar, when the moon is at its fullest and roundest. 
bubuko.com,布布扣

The traditional food of this festival is the mooncake. Chinese family members and friends will gather to admire the bright mid-autumn harvest moon, and eat mooncakes under the moon together. In Chinese, “round”(圆) also means something like “faultless” or “reuion”, so the roundest moon, and the round mooncakes make the Zhongqiu Festival a day of family reunion.

Alice has opened up a 24-hour mooncake shop. She always gets a lot of orders. Only when the time is K o’clock sharp( K = 0,1,2 …. 23) she can make mooncakes, and We assume that making cakes takes no time. Due to the fluctuation of the price of the ingredients, the cost of a mooncake varies from hour to hour. She can make mooncakes when the order comes,or she can make mooncakes earlier than needed and store them in a fridge. The cost to store a mooncake for an hour is S and the storage life of a mooncake is T hours. She now asks you for help to work out a plan to minimize the cost to fulfill the orders.
 

Input
The input contains no more than 10 test cases. 
For each test case:
The first line includes two integers N and M. N is the total number of orders. M is the number of hours the shop opens. 
The next N lines describe all the orders. Each line is in the following format:

month date year H R

It means that on a certain date, a customer orders R mooncakes at H o’clock. “month” is in the format of abbreviation, so it could be "Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", "Aug", "Sep", "Oct", "Nov" or "Dec". H and R are all integers. 
All the orders are sorted by the time in increasing order. 
The next line contains T and S meaning that the storage life of a mooncake is T hours and the cost to store a mooncake for an hour is S.
Finally, M lines follow. Among those M lines, the ith line( i starts from 1) contains a integer indicating the cost to make a mooncake during the ith hour . The cost is no more than 10000. Jan 1st 2000 0 o‘clock belongs to the 1st hour, Jan 1st 2000 1 o‘clock belongs to the 2nd hour, …… and so on.

(0<N <= 2500; 0 < M,T <=100000; 0<=S <= 200; R<=10000 ; 0<=H<24)

The input ends with N = 0 and M = 0.
 

Output
You should output one line for each test case: the minimum cost. 
 

Sample Input
1 10 Jan 1 2000 9 10 5 2 20 20 20 10 10 8 7 9 5 10 0 0
 

Sample Output
70
Hint
“Jan 1 2000 9 10” means in Jan 1st 2000 at 9 o‘clock , there‘s a consumer ordering 10 mooncakes. Maybe you should use 64-bit signed integers. The answer will fit into a 64-bit signed integer.
 

Source

题意:一个月饼店只在整点工作。在整点可以制作任意多个月饼。但是在不同的时间制作月饼花费的代价不一样。而且如果一个月饼做好后储存。每小时将花费S。但是储存时间不超过T。现在给你该店工作的最长时间m。和n个订单。问你完成订单的最小花费。

思路:很简单的单调队列,把日期处理成小时后,用单调队列维护下最小值就好,队列头加入新的时间点的,队列尾删除过期的。注意会有相同时间点的订单。

/**
 * @author neko01
 */
//#pragma comment(linker, "/STACK:102400000,102400000")
#include <cstdio>
#include <cstring>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <queue>
#include <vector>
#include <cmath>
#include <set>
#include <map>
using namespace std;
typedef long long LL;
#define min3(a,b,c) min(a,min(b,c))
#define max3(a,b,c) max(a,max(b,c))
#define pb push_back
#define mp(a,b) make_pair(a,b)
#define clr(a) memset(a,0,sizeof a)
#define clr1(a) memset(a,-1,sizeof a)
#define dbg(a) printf("%d\n",a)
typedef pair<int,int> pp;
const double eps=1e-8;
const double pi=acos(-1.0);
const int INF=0x7fffffff;
const LL inf=(((LL)1)<<61)+5;
char s[12][5]={"Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"};
int day[12]={31,28,31,30,31,30,31,31,30,31,30,31};
struct node{
    int h,r;
}a[2555];
bool check(int y)
{
    return ((y%4==0&&y%100!=0)||y%400==0);
}
int input()
{
    char str[5];
    int d,y,h;
    scanf("%s%d%d%d",str,&d,&y,&h);
    int t=0,tmp=0,m=1;
    for(int i=2000;i<y;i++)
    {
        if(check(i)) t+=24*366;
        else t+=24*365;
    }
    if(check(y)) day[1]=29;
    else day[1]=28;
    for(int i=0;i<12;i++)
    {
        if(strcmp(s[i],str)==0)
        {
            m=i+1;
            break;
        }
        tmp+=day[i];
    }
    t=t+(tmp+d-1)*24+h+1;
    return t;
}
int q[111111];
int p[111111];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0) break;
        for(int i=0;i<n;i++)
        {
            a[i].h=input();
            scanf("%d",&a[i].r);
           // printf("%d\n",a[i].h);
        }
        int t,s;
        scanf("%d%d",&t,&s);
        int front=0,rear=0,j=0;
        LL ans=0;
        for(int i=1;i<=m;i++)
        {
            scanf("%d",&p[i]);
            while(front<rear&&p[i]<=p[q[rear-1]]+(i-q[rear-1])*s)
                rear--;
            q[rear++]=i;
            while(j<n&&i==a[j].h)
            {
                while(q[front]+t<a[j].h) front++;  //过期
                ans+=a[j].r*(p[q[front]]+(i-q[front])*s);
                j++;
            }
        }
        printf("%I64d\n",ans);
    }
    return 0;
}



hdu4122 Alice's mooncake shop 单调队列

标签:hdu

原文地址:http://blog.csdn.net/neko01/article/details/40867385

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!