码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2147 kiki's game 博弈

时间:2014-11-06 22:04:34      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:博弈   acm   

点击打开链接链接

kiki‘s game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 40000/1000 K (Java/Others)
Total Submission(s): 6933    Accepted Submission(s): 4141


Problem Description
Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The person who can‘t make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?
 

Input
Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

 

Output
If kiki wins the game printf "Wonderful!", else "What a pity!".
 

Sample Input
5 3 5 4 6 6 0 0
 

Sample Output
What a pity! Wonderful! Wonderful!
 

Author
月野兔
 

Source
 

给出 n*m的方格 能往下往左或者左下三个方向走 从(n,m)开始

走到(1,1)的胜利 问谁能赢

#include<cstdio>
#include<cstring>
int main()
{
    int n,m;
    while(scanf("%d %d",&n,&m)!=EOF&&(n||m))
    {
        if(n%2&&m%2)
            printf("What a pity!\n");
        else
            printf("Wonderful!\n");
    }
    return 0;
}


hdu 2147 kiki's game 博弈

标签:博弈   acm   

原文地址:http://blog.csdn.net/qq_16843991/article/details/40866461

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!