码迷,mamicode.com
首页 > 其他好文 > 详细

1144 The Missing Number (20分)

时间:2020-05-02 14:56:53      阅读:58      评论:0      收藏:0      [点我收藏+]

标签:ace   test   The   clipboard   cli   --   span   bsp   space   

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17
 

Sample Output:

7

消失的数字,我们给定一串数字,求从1开始遍历,最先消失的数字。

#include <iostream>
#include <unordered_map>
using namespace std;
int N, tmp;
unordered_map<int, bool> m;
int main() {
    cin >> N;
    while(N--) {
        cin >> tmp;
        m[tmp] = 1;
    }
    for(int i = 1; i < 101000; i++) {
        if(m[i] == 0) {
            printf("%d\n", i);
            break;
        }
    }
    return 0;
}

 

1144 The Missing Number (20分)

标签:ace   test   The   clipboard   cli   --   span   bsp   space   

原文地址:https://www.cnblogs.com/littlepage/p/12818003.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!