码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3669 Meteor Shower 【BFS】

时间:2014-11-07 08:41:26      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:poj3669

Meteor Shower
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 9163   Accepted: 2594

Description

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (XiYi) (0 ≤ X≤ 300; 0 ≤ Y≤ 300) at time Ti (0 ≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

* Line 1: A single integer: M
* Lines 2..M+1: Line i+1 contains three space-separated integers: XiYi, and Ti

Output

* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input

4
0 0 2
2 1 2
1 1 2
0 3 5

Sample Output

5

Source


/*
** Problem: POJ No.3669
** Running time: 94MS 
** Complier: C++
** Author: Changmu 
**
** 题意:给定n个炸弹的爆炸地点和时间,求小明从(0,0)点跑到安全区域的最少时间。
** 题解:直接BFS。
** 坑点:没看数据范围,实际上安全区域可以在给定的范围之外,而且存在一开始就被
** 炸的可能...
*/

#include <stdio.h>
#include <string.h>
#include <queue>

#define maxn 305
#define maxT 1005

int map[maxn][maxn];
const int mov[][2] = {0, 1, 0, -1, -1, 0, 1, 0,};
int N;
struct Node {
    int x, y, t;
};

void Destory(int x, int y, int t) {
    if(map[x][y] == -1 || t < map[x][y]) 
        map[x][y] = t;
    int xa, ya;
    for(int i = 0; i < 4; ++i) {
        xa = x + mov[i][0];
        ya = y + mov[i][1];
        if(xa < 0 || ya < 0) continue;
        if(-1 == map[xa][ya] || t < map[xa][ya])
            map[xa][ya] = t;
    }
}

void getMap() {
    memset(map, -1, sizeof(map));
    int i, j, x, y, t;
    for(i = 0; i < N; ++i) {
        scanf("%d%d%d", &x, &y, &t);
        Destory(x, y, t);
    }
}

bool check(int x, int y, int t) {
    if(x < 0 || y < 0) return false;
    if(map[x][y] == -1 || map[x][y] > t) 
        return true;
    return false;
}

int BFS() {
    if(map[0][0] == -1) return 0;
    if(!map[0][0]) return -1;
    std::queue<Node> Q;
    Node u, v;
    u.x = u.y = u.t = 0;
    Q.push(u);
    while(!Q.empty()) {
        u = Q.front(); Q.pop();
        for(int i = 0; i < 4; ++i) {
            v = u; ++v.t;
            v.x += mov[i][0];
            v.y += mov[i][1];
            if(check(v.x, v.y, v.t)) {
                if(map[v.x][v.y] == -1)
                    return v.t;
                map[v.x][v.y] = 0;
                Q.push(v);
            }
        }
    }
    return -1;
}

int main() {
    // freopen("stdin.txt", "r", stdin);
    while(scanf("%d", &N) == 1) {
        getMap();
        printf("%d\n", BFS());
    }
    return 0;
}


POJ3669 Meteor Shower 【BFS】

标签:poj3669

原文地址:http://blog.csdn.net/chang_mu/article/details/40869339

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!