码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 4737 A Bit Fun(2013 成都网络赛)

时间:2014-11-07 11:22:12      阅读:124      评论:0      收藏:0      [点我收藏+]

标签:algorithm   matrix   

A Bit Fun

                                                  Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                       Total Submission(s): 2089    Accepted Submission(s): 1040


Problem Description
There are n numbers in a array, as a0, a1 ... , an-1, and another number m. We define a function f(i, j) = ai|ai+1|ai+2| ... | aj . Where "|" is the bit-OR operation. (i <= j)
The problem is really simple: please count the number of different pairs of (i, j) where f(i, j) < m.
 

Input
The first line has a number T (T <= 50) , indicating the number of test cases.
For each test case, first line contains two numbers n and m.(1 <= n <= 100000, 1 <= m <= 230) Then n numbers come in the second line which is the array a, where 1 <= ai <= 230.
 

Output
For every case, you should output "Case #t: " at first, without quotes. The t is the case number starting from 1.
Then follows the answer.
 

Sample Input
2 3 6 1 3 5 2 4 5 4
 

Sample Output
Case #1: 4 Case #2: 0
 

用个数组记录下各位出现的次数,就可以实现在一段区间或的值中减去一个元素。

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <vector>
#include <string>
#include <map>
#include <cstdlib>
#include <ctime>
using namespace std;
const int maxn=100000+1000;
int a[maxn];
int h[100];
int n,m;
void add(int x)
{
    int cur=0;
    while(x)
    {
        h[cur++]+=(x%2);
        x=x/2;
    }
}
void del(int x)
{
    int cur=0;
    while(x)
    {
        h[cur++]-=(x%2);
        x=x/2;
    }
}
int re()
{
    int ans=0;
    for(int i=0; i<35; i++)
    {
        if(h[i]>0)
            ans+=(1<<i);
    }
    return ans;
}
int main()
{
    int t,ca=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        memset(h,0,sizeof(h));
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        int temp=0;
        long long ans=0;
        int cur=0;
        for(int i=0; i<n; i++)
        {
            cur=max(i,cur);
            while((temp|a[cur])<m&&cur<n)
            {
                temp=(temp|a[cur]);
                add(a[cur]);
                cur++;
            }
            if(cur>i)
            {
                ans+=(cur-i);
                del(a[i]);
                temp=re();
            }
        }
        printf("Case #%d: ",ca++);
        cout<<ans<<endl;
    }
    return 0;
}


hdu 4737 A Bit Fun(2013 成都网络赛)

标签:algorithm   matrix   

原文地址:http://blog.csdn.net/caduca/article/details/40889187

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!