标签:city orm lse names you 包含 就是 git flag
A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.
Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N > 0 in base b >= 2, where it is written in standard notation with k+1 digits ai as the sum of (aibi) for i from 0 to k. Here, as usual, 0 <= ai < b for all i and ak is non-zero. Then N is palindromic if and only if ai = ak-i for all i. Zero is written 0 in any base and is also palindromic by definition.
Given any non-negative decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.
Input Specification:
Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10?9?? is the decimal number and 2≤b≤10?9?? is the base. The numbers are separated by a space.
Output Specification:
For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a?k?? a?k?1? ... a?0?? ". Notice that there must be no extra space at the end of output.
Sample Input 1:
27 2
Sample Output 1:
Yes
1 1 0 1 1
Sample Input 2:
121 5
Sample Output 2:
No
4 4 1
给定一个十进制数N
和一个进制base
,问n的base进制下的表示是不是一个回文数,如果是,输出“Yes”换行,输出它的base进制序列;如果不是,输出“No”,输出它的base进制。
把N转成base进制,用数组存储就好
了。注意扫描时左右指针的取值范围,不要漏掉某个位置元素
,我就因为这个问题在测试点3卡了半天没想明白。#include <iostream>
using namespace std;
int main() {
// 回文数字
int n, base;
cin >> n >> base;
// 把n转成base进制,再判断是不是对称位置都相等即可
int arr[50] = {0};
int i = 0;
do {
arr[i++] = n % base;
n = n / base;
} while (n > 0);
// do while结束后,i停留在最后一个有效位的后一位置
i -= 1;
bool flag = true;
// 判断是否 "对称",注意这里的 j <= i / 2
for (int j = 0; j <= i / 2; ++j) {
if (arr[j] != arr[i - j]) {
flag = false;
break;
}
}
cout << (flag ? "Yes" : "No") << endl;
// 输出base进制编码
while (i >= 1)
cout << arr[i--] << " ";
cout << arr[0];
return 0;
}
1019 General Palindromic Number (20分)
标签:city orm lse names you 包含 就是 git flag
原文地址:https://www.cnblogs.com/codervivi/p/12885464.html