码迷,mamicode.com
首页 > 其他好文 > 详细

6-3 将整数中每一位上为偶数的数依次取出构成新数

时间:2020-05-15 09:58:25      阅读:224      评论:0      收藏:0      [点我收藏+]

标签:输入   整数   std   lag   ==   类型   ret   The   测试   

给定函数fun的功能是:将长整型数中每一位上为偶数的数依次取出,构成一个新数放在t中。高位仍在高位,低位仍在低位。例如,当s中的数为:87653142时,t中的数为:8642。。

函数接口定义:

void fun (long s, long *t);
 

其中 st 是用户传入的参数。函数将整数 s 中每一位上为偶数的数依次取出,构成一个新数放在t指针所指的变量中。

裁判测试程序样例:

#include <stdio.h> 
void fun (long s, long *t);
int main()
{ long s, t;
 scanf("%ld", &s);
 fun(s, &t);
 printf("The result is: %ld\n", t);
 return 0;
}


/* 请在这里填写答案 */

 

 

输入样例:

87653142

 

输出样例:

The result is: 8642

 

#include <stdio.h> 
void fun (long s, long *t);
int main()
{ long s, t;
 scanf("%ld", &s);
 fun(s, &t);
 printf("The result is: %ld\n", t);
 return 0;
}

void fun (long s, long *t)//本题采用的不是数组类型,所以使用整数中的除与取余数来做 
{
	int sum = 0;
	int flag = 1;
	while(s > 0)
	{
		if(s % 10 % 2 == 0)
		{
			sum += s % 10 * flag;
			flag *= 10;
		}
		s /= 10;
	}
	*t = sum;
}

 

 

6-3 将整数中每一位上为偶数的数依次取出构成新数

标签:输入   整数   std   lag   ==   类型   ret   The   测试   

原文地址:https://www.cnblogs.com/rebloom000/p/12892751.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!