码迷,mamicode.com
首页 > 其他好文 > 详细

hdu2899——Strange fuction

时间:2014-11-07 17:02:08      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:二分   数学   

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3344    Accepted Submission(s): 2446


Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
2 100 200
 

Sample Output
-74.4291 -178.8534
 

Author
Redow
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  2199 2289 2298 2141 3400

对这个函数连续求几次导可以发现,对于此函数的导函数,如果y <= 0,那么函数在[0, 100]内单调递增,所以最小值是0
如果y>0,观察其导函数,发现导函数单调递增,所以我们只要找到导函数的零点(即原函数的极小值点),此时可以用二分解决
找到极值点以后,如果它在[0, 100],就把它代入函数,否则说明函数在[0, 100]内单调递减,把100代入函数即可

#include <map>  
#include <set>  
#include <list>  
#include <stack>  
#include <queue>  
#include <vector>  
#include <cmath>  
#include <cstdio>  
#include <cstring>  
#include <iostream>  
#include <algorithm>

using namespace std;

int main()
{
	int t;
	scanf("%d\n", &t);
	while (t--)
	{
		double y;
		scanf("%lf", &y);
		if (y <= 0)
		{
			printf("0.0000\n");
			continue;
		}
		double l = 0, r = 100, mid;
		while(r - l > 1e-6)
		{
			mid = (l + r) / 2;
			double dx = 42.0 * pow(mid, 6) + 48.0 *  pow(mid, 5) + 21.0 *  pow(mid, 2) + 10.0 * mid;
			if (abs(dx - y) < 1e-6)
			{
				break;
			}
			else if(dx - y > 1e-6)
			{
				r = mid;
			}
			else
			{
				l = mid;
			}
		}
		if (mid - 100.0 > 1e-6)
		{
			mid = 100.0;
		}
		double ans = 6 *  pow(mid, 7) + 8 *  pow(mid, 6) + 7 * pow(mid, 3) + 5 *  pow(mid, 2) - y * mid; 
		printf("%.4f\n", ans);
	}
	return 0;
} 


hdu2899——Strange fuction

标签:二分   数学   

原文地址:http://blog.csdn.net/guard_mine/article/details/40894283

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!