码迷,mamicode.com
首页 > 其他好文 > 详细

1031 Hello World for U (20分)

时间:2020-05-17 01:18:46      阅读:53      评论:0      收藏:0      [点我收藏+]

标签:ann   string   mes   NPU   main   prope   lin   origin   put   

Given any string of N (≥) characters, you are asked to form the characters into the shape of U. For example, helloworld can be printed as:

h  d
e  l
l  r
lowo
 

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n?1?? characters, then left to right along the bottom line with n?2?? characters, and finally bottom-up along the vertical line with n?3?? characters. And more, we would like U to be as squared as possible -- that is, it must be satisfied that n?1??=n?3??=max { k | kn?2?? for all 3 } with n?1??+n?2??+n?3??2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!
 

Sample Output:

h   !
e   d
l   l
lowor


n1+n2+n3-2 = n;
n1=n3所以-> 2*n1 + n2 = n+2
因为n2>n1
所以n1 = n/3, n2 = n/3 + n%3



#include<iostream>
#include<string.h>
using namespace std;

int main()

{
    char c[81]={ };
    char u[30][30];
    scanf("%s",&c);
    memset(u, ,sizeof(u));

    int n = strlen(c)+2;

    int n1 = n/3; int n2 = n/3 + n%3;
    int j=0;
    for(int i=0;i<n1;i++)
        u[i][0] = c[j++];
    for(int i=1;i<=n2-2;i++)//注意要减去二,因为倒u型的底部有两个重合
        u[n1-1][i] = c[j++];
    for(int i=n1-1;i>=0;i--)
        u[i][n2-1]=c[j++];

    for(int i=0;i<n1;i++)
    {
        for(int j=0;j<n2;j++)
        {
            printf("%c",u[i][j]);
        }
        printf("\n");
    }


    return 0;
}

 

1031 Hello World for U (20分)

标签:ann   string   mes   NPU   main   prope   lin   origin   put   

原文地址:https://www.cnblogs.com/qinmin/p/12902918.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!