码迷,mamicode.com
首页 > 其他好文 > 详细

[ACM] SDUT 2883 Hearthstone II (第二类Stiring数)

时间:2014-11-07 20:49:50      阅读:282      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   io   color   ar   os   java   

Hearthstone II

Time Limit: 2000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

The new season has begun, you have n competitions and m well prepared decks during the new season. Each competition you could use any deck you want, but each of the decks must be used at least once. Now you wonder how many ways are there to plan the season — to decide for each competition which deck you are going to used. The number can be very huge, mod it with 10^9 + 7.
 

输入

The input ?le contains several test cases, one line for each case contains two integer numbers n and m (1?≤?m?≤?n?≤?100).
 

输出

One line for each case, output one number — the number of ways.

示例输入

3 2
100 25

示例输出

6
354076161

提示

 

来源

2014年山东省第五届ACM大学生程序设计竞赛


解题思路:

题意为n个竞赛要用到m张桌子,每张桌子至少被用一次,桌子不同,问一共有多少种安排方法。

也就是把n个元素分到m个非空且不可区分的集合中去。第二类Stiring数   s(n,m)意思是把n个元素分到m个非空且不可区分的集合中去。本题集合(桌子)是可区分的,那么答案为

m! *s(n,m).

知识详解见:http://blog.csdn.net/sr_19930829/article/details/40888349

代码:

#include <iostream>  
#include <string.h>  
using namespace std;  
const int maxn=102;  
const int mod=1e9+7;  
typedef long long ll;  
ll s[maxn][maxn];  
int n, m;  
  
void init()  
{  
    memset(s,0,sizeof(s));  
    s[1][1]=1;  
    for(int i=2;i<=100;i++)  
        for(int j=1;j<=i;j++)  
            {  
                s[i][j]=s[i-1][j-1]+j*s[i-1][j];  
                if(s[i][j]>=mod)  
                    s[i][j]%=mod;  
            }  
}  
  
ll solve(int n,int m)  
{  
    ll ans=s[n][m];  
    for(int i=2;i<=m;i++)  
    {  
        ans*=i;  
        if(ans>=mod)  
            ans%=mod;  
    }  
    return ans;  
}  
  
int main()  
{  
    init();  
    while(cin>>n>>m)  
    {  
        cout<<solve(n,m)<<endl;  
    }  
    return 0;  
}



[ACM] SDUT 2883 Hearthstone II (第二类Stiring数)

标签:des   style   blog   http   io   color   ar   os   java   

原文地址:http://blog.csdn.net/sr_19930829/article/details/40898511

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!