码迷,mamicode.com
首页 > 其他好文 > 详细

DFS HDU 2614

时间:2014-11-07 20:55:27      阅读:262      评论:0      收藏:0      [点我收藏+]

标签:dfs

很水的。但是wa了很多遍,因为写num【1】【1】。。。

改成0之后就过了。。。虽然不知道为什么。。。

Beat

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 659    Accepted Submission(s): 415


Problem Description
Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve
a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one.
You should help zty to find a order of solving problems to solve more difficulty problem.
You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve.
 

Input
The input contains multiple test cases.
Each test case include, first one integer n ( 2< n < 15).express the number of problem.
Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j.
 

Output
For each test case output the maximum number of problem zty can solved.


 

Sample Input
3 0 0 0 1 0 1 1 0 0 3 0 2 2 1 0 1 1 1 0 5 0 1 2 3 1 0 0 2 3 1 0 0 0 3 1 0 0 0 0 2 0 0 0 0 0
 

Sample Output
3 2 4
Hint
Hint: sample one, as we know zty always solve problem 0 by costing 0 minute. So after solving problem 0, he can choose problem 1 and problem 2, because T01 >=0 and T02>=0. But if zty chooses to solve problem 1, he can not solve problem 2, because T12 < T01. So zty can choose solve the problem 2 second, than solve the problem 1.
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <queue>
#include <stack>
#include <deque>
#include <vector>
#include <set>
#include <map>
using namespace std;
#define MAXN 20

int num[MAXN][MAXN];
int vis[200];
int n;
int ans;

int Max(int a,int b){
    return a>b?a:b;
}

void DFS(int h,int count,int t){
    int i;
    ans = Max(ans,t);
    for(i=1;i<=n;i++){
        /*if(vis[i] == 1){
            continue;
        }
        if(num[h][i] < count){
            continue;
        }*/
        if(vis[i]==0 && num[h][i]>=count){
            vis[i] = 1;
            DFS(i,num[h][i],t+1);
            vis[i] = 0;
        }
        /*vis[i] = 1;
        DFS(i,num[h][i],t+1);
        vis[i] = 0;*/
   }
}

int main(){
    int i,j;

    while(~scanf("%d",&n)){
        memset(vis,0,sizeof(vis));
        /*for(i=0;i<MAXN;i++){
            for(j=0;j<MAXN;j++){
                num[i][j] = 0;
            }
        }*/
        for(i=1;i<=n;i++){
            for(j=1;j<=n;j++){
                scanf("%d",&num[i][j]);
            }
        }
        vis[1] = 1;
        ans = 0;
        //printf("%d\n",num[1][1]);
        DFS(1,0,1);
        printf("%d\n",ans);
    }

    return 0;
}


DFS HDU 2614

标签:dfs

原文地址:http://blog.csdn.net/zcr_7/article/details/40897625

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!