码迷,mamicode.com
首页 > 其他好文 > 详细

UVA 644 Immediate Decodability (字符处理)

时间:2014-11-08 07:05:41      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:des   style   io   color   ar   os   sp   for   strong   

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.


Examples: Assume an alphabet that has symbols {A, B, C, D}


The following code is immediately decodable:


A:01 B:10 C:0010 D:0000


but this one is not:


A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input 

Write a program that accepts as input a series of groups of records from a data file. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output 

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.


The Sample Input describes the examples above.

Sample Input 

01
10
0010
0000
9
01
10
010
0000
9

Sample Output 

Set 1 is immediately decodable
Set 2 is not immediately decodable

一个串不能是另一个串的前缀。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
typedef long long LL;
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
//map<string,int>q;
char str[1100][10],s[10];
int main()
{
    int cas=1;
     std::ios::sync_with_stdio(false);
     while(cin>>str[0])
     {
         int l=1;
         char *p;
         while(cin>>str[l]&&str[l++][0]!='9');
         int flag=1;
         REP(i,l-1)
         {
             REP(j,l-1)
             {
                 if(i==j)  continue;
                 p=strstr(str[i],str[j]);
                 if((p-str[i])==0)
                 {
                     flag=0;
                     break;
                 }
             }
         }
         if(flag)  printf("Set %d is immediately decodable\n",cas++);
         else     printf("Set %d is not immediately decodable\n",cas++);
     }
     return 0;
}


UVA 644 Immediate Decodability (字符处理)

标签:des   style   io   color   ar   os   sp   for   strong   

原文地址:http://blog.csdn.net/u013582254/article/details/40915481

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!